Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hey, I just got a new laptop (Thinkpad W500) and installed Kubuntu Karmic Koala on it and it seems it doesn't detect my wifi card at all, which is a Thinkpad wifi bgn( Realtek 8172 chipset). Any help on this, please?

Edit I've tried lspci (nothing shows up), lsusb (the same), wifi is enabled from bios, it works fine under windows 7. Also, I've tried an older version of ubuntu and it still doesn't show up.

More details: I've tried using ndiswrapper (doesn't work on karmic 64 bit), tried the realtek driver ... doesn't work either. I've switched to karmic 32 bit for ndiswrapper and it's not working for that either. While I was there I tried to use madwifi with a pae kernel - obviously that failed gloriously.

I really need a super user!

share|improve this question
more details please. thinkpad model? wifi chipset (if you know)? – quack quixote Nov 25 '09 at 1:23

There are lots of complaints concerning Wi-Fi compatibility. Probably, you have RaLink chipset or even worse: manufacturers often ignore Linux support, or provide BUGGY-LAGGY drivers (Hey, ASUS!). The Wi-Fi situation is pain in the ass, really...

Check these links: WirelessCardsSupported and Linux wireless LAN support and find out whether it's compatible.

The most painless solution is to buy an adapter which works like a charm. Atheros chips are VERY good, and here's an excellent Atheros-inside unit TP-LINK TL-WN821N: rather cheap, powerful (20dBm transmitter!), 802.11N and works out of the box. There are more wireless devices that work nice, but I swear this one really works!

Cheers! :)

share|improve this answer
You mean Realtek chipsets? – hyperboreean Nov 25 '09 at 7:41
No, RaLinkTech: . "LINUX SUPPORTED!" thay say, but in reality this crap does nothing but loading the kernel =\ – kolypto Nov 25 '09 at 17:38

I had the same issue when installing ubuntu onto my no-name netbook (no brand name made it very hard to source drivers).

Ended up getting the solution by doing

sudo lshw


        description: Wireless interface
        product: RT3090 Wireless 802.11n 1T/1R PCIe
        vendor: RaLink

Googling "RT3090 linux driver", and finding this page.

After installing the driver, to make turn it on (and autostart)

sudo modprobe rt3090sta

This was back with 9.04 (Jaunty) but that page has been updated and works with 9.10 Karmic also.

share|improve this answer
well, I don't have a ralink card, it's a realtek one – hyperboreean Nov 25 '09 at 23:16
when you 'sudo lshw' do you get a network product definition like above? you could follow a similar process. – Dean Rather Nov 26 '09 at 0:00
up vote 0 down vote accepted

The driver and the patch for 64 bit available at did the work for me ... it works like a charm now. Next step: make ATI work with karmic which as a big PITA as the wifi card was.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .