Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying building apache with mod_ssl and I am running into issues becuase my OpenSSL version is less than 0.9.8a. I tried updating but yum says I have the latest version ( 0.9.8e-27.el5_10.1, which already appears to be greater than the required...)

Can I install the latest openssl rpm for CentOS 6.5 distro? What are my options?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Answer for the first question is no. It would break your system. I don't know particularly CentOS but it seems doing yum install mod_ssl is sufficient to get mod_ssl. If you really need to compile it yourself, you have to install the OpenSSL's development packages: yum install openssl-devel.

share|improve this answer
    
I am building apache for a non-root user. yum install openssl-devel was what I needed. Thanks. –  yellavon May 6 at 16:24

My Centos 6.5 openssl is at 1.0.1e-16.el6_5.7 (which fyi includes the heartbleed fix) and was installed via yum.

Make sure you have the repo configured and enabled in /etc/yum.repos.d/CentOS-Base.repo. Mine has a stanza like this:

#released updates 
[updates]
name=CentOS-$releasever - Updates
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates
gpgcheck=1
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6

Then it should simply be a case of yum update openssl. It will inform you of dependencies and prompt you for confirmation before installing anything.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.