Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to get a Linux Mint Debian Edition 16 USB key booting.

On a Win7 machine, using linuxmint-201403-mate-dvd-64bit.iso (or 32-bit, they both do this), I used LiLi and forced it to use the latest LMDE it knew about (201303, I think) to create the USB stick. For both 64- and 32-bit LMDE sticks, I can boot to them on my 64-bit desktop box*, but the text-mode menu where you can choose live, persistent, file integrity check, or memory test, and it counts down from 10, none of the options do what they say. All of them simply cause an instant screen flicker and the menu's countdown is back at 10 seconds and counting down again.

* An AMD Sempron-based system that runs Haiku 64-bit nightlies OK, so I know it can, in general, run a 64-bit OS.

The 32-bit one I also tried in a (32-bit only) netbook, and it did the exact same thing.

On both of these systems--my desktop and my netbook--linuxmint-16-mate-dvd-32bit.iso worked fine in the default mode (live or persistent, I don't remember ATM) and I also ran the installer to install to HD. However, as they're older systems and a bit slow to load, I was hoping to try the Debian Edition, because it was said to be faster. I didn't expect this much trouble. How can I get an LMDE USB stick to actually boot up the full OS, like the normal Ubuntu-based Linux Mint does?

Also tried: I got Universal-USB-Installer and UNetbootin, but they both suffer from the problem of not having a "Mint Debian Edition" option and guessing which one to override with is beyond me, but if anyone knows that would be great.


  • Ubuntu Mint 32 on desktop: fine
  • Ubuntu Mint 32 on netbook: fine
  • Debian Mint 32 on desktop: broken
  • Debian Mint 32 on netbook: broken
  • Debian Mint 64 on destkop: broken


broken = will not boot past Mint boot menu, but just keeps looping back to it no matter the menu item chosen

fine = actually boots Mint normally with a GUI and installer and such

share|improve this question
What is your actual question? Also, what model/make is your netbook? This questions seems to be very specific to your netbook and distro but you forgot to tell use what model/make your netbook is.. Is the problem with your netbook or desktop? I've never been a big fan of Mint, but to each his own. – Richie086 May 5 '14 at 23:57
Sorry, I thought the problem was clear: how to get it to do something besides jump back to the Mint boot menu, i.e., actually boot the Mint OS... Netbook is an hp mini 1101, and it's not specific to that, as you can see reading the OP, my desktop has the exact same issue with both the 32-bit and 64-bit, whereas the ubuntu-based Mint 16 runs fine on both systems. – Kev May 6 '14 at 0:28
Should this be at the unix & linux SE? – Kev May 6 '14 at 2:42
@Richie086 please read my post. Your questions aside from the notebook model were all answered before I ever edited, but I tried to edit to make it even clearer. – Kev May 6 '14 at 12:04

I have had this problem before. How did you mount the iso onto the USB? If you used unetbootin, there are known issues with it. If you have access to a Windows computer, use the PenDriveLinux website. I've not had problems with it yet. I think Unetbootin doesn't properly format USB disks with some computers (I have a Dell Inspiron 1525). My suggestion is to spend a lot of time PROPERLY formatting your USB to NTFS or FAT32 (either is fine). Make sure you go through the process of entirely erasing all previous filesystems and data. Then remount the iso using something other than Unetbootin. It worked for me, but I had to spend a lot of time reformatting the USB.

Another possible problem(unlikely) is that your USB is damaged. Try with another one. Most probably, the solution is the former

share|improve this answer
I number of your statements and questions are answered in the OP. How did I mount? "I used LiLi" "on a Win7 machine" per OP but also PenDriveLinux doesn't have an LDME option per OP, so which should I use? I came here for help after making my 5th stick so as to avoid having to try every single option in case someone already successfully did this (surely someone...?) In any case with LiLi I always used the format option (FAT32 is the only choice it gives). You used PenDriveLinux, which doesn't mention LDME, so then, which distro's instructions did you use? – Kev May 6 '14 at 12:03
And it's possible the USB is damaged, but why would LDME not work when Ubuntu-based Mint works fine from the exact same USB stick? – Kev May 6 '14 at 19:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .