Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to open a CR2 file shot by a Canon EOS 5D Mark II, but it doesn't show up on Mac OS X 10.6.

When I go to file info, it shows me the Device make, Device Model, focal length, etc. but Dimensions are 0x0 and the photos doesn't show up.

Why might this be happening, and how can I fix this?

share|improve this question
    
Do you see them in Photoloader? Or what program do you try to use? –  bert Nov 25 '09 at 8:00
    
Your link is no longer valid. –  user3463 Aug 12 '12 at 5:55

2 Answers 2

The file is not corrupted. I downloaded it and it opens fine.

The 5D Mk II has two sRAW formats, which allows a smaller RAW file than the 22 megapixel native size. The sample photo you have linked is a larger of the two sRAW types the 5D Mk II supports, 9.9 megapixel.

Different raw processing software has problems converting the sRAW files though. If you have Photoshop CS4 and a relatively new Camera Raw software. Camera Raw 5.5 mac/win is current, although there is a prerelease Camera Raw 5.6 version on Adobe Labs, you'll be able to open them.

EDIT: If you have an earlier version of Photoshop, you can use the DNG Converter (mac/win) to convert the RAW file into something you can open in an earlier version of Photoshop. However, I think you'll find if you shoot with the full resolution RAW format, it's more compatible than the sRAW formats.

EDIT2: Screenshot of the converted image:

enter image description here

share|improve this answer
    
I have CS4 and all the updates and it still doesn't open. –  Hasaan Chop Nov 25 '09 at 3:32
1  
Did you rename the file .CR2 after you downloaded it? After I downloaded it, it was named .TIFF –  emgee Nov 25 '09 at 3:39
    
FWIW, this worked fine in Lightroom for myself. Apple's own built-in RAW converter does not seem able to handle these specific RAW files. –  Chealion Nov 25 '09 at 6:27
    
Lightroom and Photoshop both use Adobe Camera Raw to process raw file — which processes sRAW files fine. –  emgee Nov 25 '09 at 17:20

It's because you haven't updated your drivers. I have the 5D mark II and I had to update my drivers to get photoshop CS4 to recognize my files.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.