Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have this Ubuntu Server running in my room and i wanted to use it as an alarm clock, so i decided to make a C++ program for it (i know i could've used cron but meh). The problem is the fact that i can't get any sound to play from my speaker (i had installed Media Player Daemon(MPD) with mpc's interface). When i try to play some music over SSH, using mpc, nothing plays from the server's speaker.

I know that i am probably not furnishing enough info but i can supply more if you ask!

(my mpd is setup to use ALSA)

i have to log as root to use alsa apparently... when i try the first command it works fine, the second tells me: "Unable to find simple control 'PCM, 0" also, i tried this on Headphone, Front, but while using amixer, i noticed that it says that even at 100% these device have 0.0dB....maybe that'S not normal...

answer to your questions:

  1. i used the the server edition (with LAMP)
  2. it is not running any X stuff.
  3. only the services are started when the machine start, i never have to physically logon
  4. i login using ssh but since it doesn't have X, i cannot use the X argument.
  5. i did not try this, in fact installing X isn't really an option for me...
share|improve this question
    
did you ever get this working? what's your sound chipset? –  quack quixote Jan 5 '10 at 7:37
    
Any chance you got this working , still looking for answer –  RC1140 Apr 29 '10 at 8:47
add comment

2 Answers 2

Simple things first. Is it possible that the alsa mixer is muted by default?

Try:

amixer set Master 100% unmute
amixer set PCM 100% unmute

Anything?

Questions:

  1. How did you install 9.04? Did you start from the Alternate iso? The Server edition?
  2. Is the server running X?
  3. What's starting when the machine starts? or are you intending to have some user persistently logged into this machine?
  4. How are you logging in? Something like ssh -X user@headless?
  5. Have you tried existing archives like this or this?
share|improve this answer
add comment

If you add your user to the audio group, you will be able to start alsa sound from a ssh connection. Do this:

sudo usermod -a -G audio username

on the server.

Only members of the audio group can use the sound system when not logged in. When you connect via ssh, you're not logged in.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.