Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've prepended each of my bash config files (~/.bashrc,~/.bash_profile,~/.profile) with echo NAME_OF_FILE, i.e. I get '.bashrc' when I source in ~/.bashrc.

What baffles me is why I get and indication that ~/.bashrc gets included when I run a command over ssh. E.g., if I do:

ssh localhost echo hi

I get

.bashrc
hi

Why is getting ~/.bashrc sourced in in this context? Shouldn't it NOT get sourced in since this should run an non-interactive bash session?

Indeed, ssh localhost tty gets me a 'not a tty' (preceded by '.bashrc' indicating that ~/.bashrc gets sourced in nonetheless).

I've grepped all my config files for commands sourcing in ~/.bashrc explicitly, and there are none that explain it.

(I only have tty -s && shopt -q login_shell && [[ -r ~/.bashrc ]] && . ~/.bashrc in my .bash_profile so that I get '.bashrc' even in interactive login shells, but this doesn't explain the ssh issue—I can comment it out and I still get the same behavior with the above ssh examples)

How can I debug this?

share|improve this question
    
Could it be your BASH_ENV variable? –  m4573r May 7 '14 at 11:22

1 Answer 1

up vote 2 down vote accepted

From bash man page:

Bash attempts to determine when it is being run with its standard input
connected to a a network  con‐nection,  as  if  by  the remote shell daemon,
usually rshd, or the secure shell daemon sshd.  If bash
determines it is being run in this fashion, it reads and executes commands
from  ~/.bashrc,  if  that file  exists and is readable.

I.e. ~/.bashrc will get run when you invoke it via ssh, regardless of whether you have a tty or not.

If you only want your .bashrc to run when you are interactive, try this at the top:

# If not running interactively, don't do anything
[[ "$-" != *i* ]] && return

If that doesn't work, try this:

[ -z "$PS1" ] && return
share|improve this answer
1  
The manual page is a bit unclear, as most remote connection tools – rshd, telnetd, sshd – attach bash's stdin/stdout to a pseudoterminal, not directly to the network socket (which would actually be impossible for sshd). Will check the source code later. –  grawity May 7 '14 at 14:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.