Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Hamachi to create a network between computers behind different routers. I am connected to 2 computers - both are behind routers. One computer (Computer A) is a "relayed (slow)" connection, and one computer (Computer B) is a "ready" (fast) connection.

Computer B has a "ready" (fast) connection to computer A, so I know it is possible to have a non-relayed connection to computer A, but for some reason I cannot get it to work. Any suggestions to be able to have a fast connection to both computers using Hamachi?

share|improve this question

2 Answers 2

thats a good question and the anwser involves a few things. All your friends need to be at their computer and you will need to turn off each one either by right clicking and " GO OFFLINE" then go online again and see what connection is given. or by having them press the power button to log off and log back in again. Some thing to consider is if they are on different ISP they might not be playing nice between say a Cable connection with a dsl connection. If your downloading or using the internet extensivly then you will get a 'relayed' connection.i have to get someone to log off and log back in to get a 'green connection' including MYSELF. Try these and maybe it might work. Check the pings could give you a answer of what is going on. One last thing you can do is if you are playing games or the like just have the one computer with 2 green connections be the SERVER, at least its a green connection for the both of you.

share|improve this answer
    
then of course for gamming you can use Tunngle. OR if it is for data sharing then openvpn or windows vpn can help. –  mike Nov 25 '09 at 19:15
up vote 0 down vote accepted

I found out how to fix this problem:

The problem is that I am behind a NAT router. You have to forward a UDP port to your computer (pick any random number that is not commonly used), make it forward to your local computer's address (probably 192.168.1.XX), and then in Hamachi's settings make sure you define the UDP port to be that number you chose. Restart Hamachi, and you should be good.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.