Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to move stuff like temp and the pagefile to an old 120GB IDE drive I found lying around, so that that thing can take some of the wear off my nice SSD C:\ drive before IDE goes the way of the dodo. The pagefile is acting really screwy. Basically, these two threads outline what should be the process.

How can I move the page file to another physical disk location?

Change the volume the windows page file is on

But they don't encounter my problem. I follow the procedure and allocate 1-4GB onto my IDE drive B:. I've tried all sorts of amounts in that range, but the result is always the same. If I set C:\ to have no pagefile, I reboot and Windows says there was an error with the pagefile configuration and creates a 4GB one on C:. No pagefile.sys on B:\ can be found when I do the checkbox to see hidden files.

If I put the minimum pagefile amount on C:\ of 16MB, then my PC boots up without a dialog, and I have 16MB more of memory available listed in the task manager under COMMIT even though I told it 16MB on C:\ and 2GB on B:\ or whatever. No pagefile.sys can be found on B:\ again.

In both cases, if I reenter the pagefile configuration menu again, change or don't change anything and hit OK, the pagefile is finally written to B:\ and acknowledged under COMMIT in the task manager. If I open all of my programs and get usage above my physical RAM, the pagefile on the other drive is utilised correctly and can be seen being accessed in the hard drive section of Windows' performance monitor. Until I reboot; then I have to go into the settings again to get a pagefile.

I also tried the suggestion at the end of the first thread to change the Write Debug Information setting. Makes no difference either way.

I've tried this on one of my SATA storage drives to see if it was something screwy about my PC and IDE. The phenomenon is exactly the same. Any ideas?

share|improve this question
    
You really have an IDE you know how slow those drives are? You have to be skipping a step this should work –  Ramhound May 8 at 22:01
add comment

1 Answer 1

I've seen things like this happen in cases where the registry values that set the pagefile size are corrupt.

The registry key is HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory management. The value name is PagingFiles. This is a MULTI_SZ value - if you double-click on it you will see one line per pagefile. Change it to just one line,

c:\pagefile.sys 4096 4096

Also be sure that the ExistingPageFiles string is just one line, like this:

\??\c:\pagefile.sys

Shut down, reboot, see what happens.

Needless to say, mistakes here can make your machine unbootable. However this is a case where the F8 menu and "Last Known Good" will save you. (That's true of anything under CurrentControlSet, as long as you haven't logged in before the problems are visible)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.