Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I tried to mount via terminal:

sudo mount -t ntfs-3g /dev/sdb /mnt

it shows the following message:

$ sudo mount -t ntfs-3g /dev/sdb /mnt
[sudo] password for ****: 
NTFS signature is missing.
Failed to mount '/dev/sdb': Invalid argument
The device '/dev/sdb' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

What does it mean? And how do I resolve this? My Seagate 2 TB HDD is new and initially it worked.


I am sorry but still after your suggestion again it shows like this:

$ sudo mount -t ntfs-3g /dev/sdb1 /mnt 
$MFTMirr does not match $MFT (record 0). 
Failed to mount '/dev/sdb1': Input/output error 
NTFS is either inconsistent, or there is a hardware fault, or it's a SoftRAID/FakeRAID hardware.
In the first case run chkdsk /f on Windows then reboot into Windows twice.
The usage of the /f parameter is very important! If the device is a SoftRAID/FakeRAID then first activate it and mount a different device under the /dev/mapper/ directory, (e.g. /dev/mapper/nvidia_eahaabcc1). 
Please see the 'dmraid' documentation for more details. 
share|improve this question
1  
Please check your formatting, you can't dump everything in one paragraph. Indent code by 4 spaces or use the {} button in the editor. –  slhck May 9 '14 at 9:03

1 Answer 1

/dev/sdb is the device name.... to mount the partition itself, you need to mount /dev/sdb1, assuming that sdb1 is the first partition on the disk(and probably the only one). Good luck.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.