Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I do not create a keyboard event (i.e. pressing or releasing a key) for more than 5 seconds, the numlock and other LEDs on my keyboard go off. When I'm holding a key for more than 5 seconds and the keyboard 'shuts down', I also hear the device disconnected sound in Windows 8.1.

I've never had this until I got this new keyboard, a "microsoft wired keyboard 200". My USB mouse still seems to work properly even when the keyboard shuts down.

It's really annoying because I can't hold any key (including Shift or Backspace) for more than a few seconds and I constantly see the LEDs flashing.

When I press or release a button, the keyboard will go on instantly again, but when it's done by releasing a key, the "release event" will not be sent to the PC, causing the key to be "stuck" while it actually isn't pressed. This is solved by pressing it again.

Does anyone know a solution for this problem?

share|improve this question

1 Answer 1

up vote 7 down vote accepted
+50

Go to Control Panel > Hardware and Sound > Devices and Printers

Right click on your USB Keyboard, go to Properties, then the Hardware tab.

Highlight USB Input Device (this is the part that doesn't show up under Device Manager) and click on Properties. Click on Change settings.

Go to the Power Management tab and uncheck 'Allow the computer to turn off this device to save power'

That should do it. The keyboard wont shut off after not using it, and it wont shut off from holding down a key for 5 seconds.

UPDATE: as it was asked in comments Fix: Allow the computer to turn off this device to save power is greyed out

enter image description here

It clearly shows that you can’t adjust the mouse which is an external hardware device; to be turned off / on while not in use. So how to change this settings? Well, a registry manipulation will help you to fix this. This fix is applicable to the devices supporting Plug-n-Play (PnP) capabilities. Here is how:

  • 1) Open Device Manager, by pressing Windows Key + R key combination and inputting devmgmt.msc in the Run dialog box and hit Enter.

DEVMGMT.MSC Fix: Allow the computer to turn off this device to save power is greyed out

  • 2) In the Device Manager, expand the Mice and other pointing devices, right click on the device and select Properties for which you’re facing the issue.

enter image description here

Cannot turn off Mouse 4 Fix: Allow the computer to turn off this device to save power is greyed out

  • 3) Now in the Properties window, switch to Details tab, select the Property as Driver Key. Copy the key as shown below. The last portion after \ of the Value so copied is device number which is 0000 in our case.

enter image description here Cannot turn off Mouse 5 Fix: Allow the computer to turn off this device to save power is greyed out

  • 4) Moving on, press Windows Key + R combination, type put Regedt32.exe in Run dialog box and hit Enter to open the Registry Editor.

enter image description here

REGEDIT Fix: Allow the computer to turn off this device to save power is greyed out

  • 5) Navigate to the following location:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\Driver Key

Where you have to substitute Driver Key obtained in step 3.

Cannot turn off Mouse 6 Fix: Allow the computer to turn off this device to save power is greyed out

enter image description here

  • 6) In the right pane of this location, you’ve to look for the DWORD named PnPCapabilities. If the DWORD doesn’t exists, you can create it using right click -> New -> DWORD Value. It must be having the default Value data set to 0, which means that the device is getting power even while not in use. Double click on the same DWORD to modify its Value data:

Greyed Power Mgmt 2 Fix: Allow the computer to turn off this device to save power is greyed out

enter image description here

  • 7) In the above shown box, input the Value data to 24 in order to enable computer to turn off the device while it is idle. You may now close the Registry Editor and reboot the machine to make changes effective.

That’s it!

share|improve this answer
1  
You are a hero. What a stupid move of Microsoft. I almost threw this keyboard away because I thought it was bad. Irony is, this is a Microsoft keyboard. Thanks for your answer! –  Jochem Kuijpers May 13 at 10:50
    
I just signed up to superuser just so I could upvote this. I'd upvote it a thousand times if I could. I have driven myself crazy poking at the BIOS, updating drivers, tweaking register settings, fiddling with Sticky Keys and other weird "making using the keyboard easier" (yeah right) settings. Googling "numlock turns off" only seems to find problems with numlock setting persistence across sessions. Really this is a horrible, hard to diagnose problem and it's a completely unnecessary design fail. You use a USB keyboard when your laptop is sitting on the desk, connected to mains power ! –  Bill Forster Jun 11 at 21:49
    
The 'Allow the computer to turn off this device to save power' is disabled for me. How can I enable this? –  KO. Aug 13 at 15:42
1  
@KO. please see an update part of the answer. –  Ruslan Gerasimov Aug 13 at 22:12
    
@RuslanGerasimov The fix didn't work for me. I am on Win8 64-bit. I tried both 32 & 64 bit DWORD without luck. Anything else I can try? –  KO. Aug 15 at 14:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.