Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Samsung Ultrabook series 5 notebook (NP530U3C), and recently I've been tinkering with Linux distros. I've had a dualboot setup with Windows 8 and Linux on this computer before, and all went good until I installed Crunchbang.

After rebooting from the installation the Grub menu with Fedora (the previous distro, whose partition had since been occupied with Crunch) and Windows showed up. I went into the BIOS and changed the boot mode from UEFI to CSM (which I believe to be some sort of legacy mode). This allowed a different Grub menu with Crunchbang and Windows 8 to show up; however this was still not an optimal situation since Windows would not boot from this Grub menu (it did boot from the old "Fedora Grub"). Of course, I wanted a way to have both OSes boot from the same menu, and after some searching I came across and followed this tutorial: http://crunchbang.org/forums/viewtopic.php?id=21510

I must have screwed up, though, because at that point whenever I tried to access the BIOS again (F2 key), it would go straight to Grub. To make thing even worse, I believe the USB drive wasn't higher than the HDD/Windows bootloader in the boot device order at the time I lost access to the BIOS.

At last, I thought that deleting the Crunchbang and EFI partitions would allow me to break from this situation where I could neither boot from a USB drive not enter the BIOS to change the option that would allow me to. To delete them I put the HDD in another, older laptop and booted from a Gparted live USB.

As of now, when I boot the notebook with the HDD plugged in, I am redirected to a Grub-rescue terminal. If I turn the PC on without the HDD, I can boot from live USB drives, but so far I have not had success in hotplugging and having the live system recognize the HDD.

To sum this all up: Can't access BIOS, no EFI partition, no Linux system.

Booting with HDD -> Can't boot from USB, cannot boot Windows 8, Grub-rescue prompt.

Booting without HDD -> Can boot live USBs.

If it is of any help, I can access the Windows recovery menu; however, I didn't have any luck solving my problem using it.

Thanks in advance.

share|improve this question
    
being able or not able to access the bios is not dependent on the content of any hdd or usb., so your testing or the info you provided regarding what tests you did, is somewhat problematic or suprefluous and might make things a bit complex. And you talk about with hard drive and without hard drive, it's not really clear what you mean by that at all. Do you mean the internal hdd, or do you mean a usb hdd. And i've no idea what you mean by hotplugging and having a live system recognize a hdd. It sounds like that's a different problem with the live distro you have and its recognition of usb. –  barlop May 10 at 19:17
    
When I say HDD I mean the internal hard drive, in which Windows 8 (and previously Linux) is installed. I thought that was quite clear, sorry for that confusion. When I say "booting with HDD" it means, as indicated, that I turned on the laptop with the HDD plugged in (just like any regular working laptop is turned on with its hard drive plugged in). "Booting without HDD", on the other hand, means I started the computer with the hard drive plugged off. Later, when a live system was running, I would connect the hard drive (hence hotplugging), but said live system would not recognize it. –  user321909 May 10 at 19:34
    
your testing is so superfluous re contents of partitions. But You say there's a scenario where you cant' access the BIOS at all? so when the internal drive is in the laptop you hit DEL or F1 and can't get into the BIOS. But when you unplug the internal drive, you can access the BIOS? That is bizarre and USB isn't relevant to that. But I would add though the Samsung 350 is a bit hard to navigate re booting USB - scroll down to my answer here superuser.com/questions/508271/… –  barlop May 13 at 19:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.