Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to print my excel document, it has box border, but I can't see them on print preview and when I print the document, borders are not printed. Page margins are narrow enough, Page Layout tab > Page Setup dialog > Sheet tab > see if Draft Quality is not checked.

share|improve this question

12 Answers 12

If you are playing with Page layout properties in VBA, then its possible that you turned the .Draft property under PageSetup to true.

The below line fixed the above problem for me. Changed the True to False With ActiveSheet.PageSetup.Draft = False

Hopefully, if someone happens to land upon this page with the same issue - then this simple fix may resolve the problem.

Thanks,
US

share|improve this answer

If you are using Microsoft Excel 2010+ (i.e. a version later than Office 2010), Navigate to the Layout tab. There are 4 sub-sections there namely: Page Setup, View, Print and Window.

Under the Print sub-section, check the Gridlines option.

That should do it.

share|improve this answer

I had the same problem with Excel 2010. If I printed directly from Excel the borders would not print. I had to save to pdf as a work-around. I tested every suggestion I found in the forums to no avail, then I tried disabling a recent Excel add-in that Adobe pushed out that allows you to save as Adobe pdf from the print menu in Excel. Once I disabled the add-in, the borders started printing again.

share|improve this answer

I had the same problem where I had created some small cells with a surround border for the purpose of entering a check mark if a condition applied. The complete cell border would be visible and would print prior to anything being in the cell but when I entered a check mark the left side of the border would disappear. What solved the problem was to change the cell format type from accounting to text.

share|improve this answer

None of the above worked for me, i did not want gridlines shown. What helped was at sheet option i changed print from draft to black n white.

share|improve this answer

You have to highlight the area you want printed and re-do the border, turn it off and on again. Make sure you are highlighting in the area you want printed. I found out because I clicked on the right side of the box I wanted printed and changed the border and when I went to print, the border did not print. The border showed on my sheet but not on preview or print. Then I highlighted on the left side of the box I wanted printed, turned off border and back on and voila. Hope this helps

share|improve this answer

Drag the last line and make it just a bit bigger. For example if your last line with the border is line 20, drag it a bit and then check again the print preview. That did it for me.

share|improve this answer

I found when I clicked on the cell and looked at the contents there was extra spaces after the text. Once I deleted theses extra spaces my border showed.

share|improve this answer

I have been having the same problem, and have not found any answers online.

My work around was changing the margin size to narrow, and all the borders seemed to show up in print preview. I then set it to the custom margin setting with .375" on the sides, and the borders were still there, although any bigger of a margin and the borders seemed to disappear again.

When the borders disappear, you can get them back by changing the column width, by even .001" and the border will reappear in the print preview, although that may cause a border somewhere else to disappear.

share|improve this answer

I just had this issue and I saved the document, exited Excel and re-opened and then tried adding the border and it worked.

Our network settings don't allow us to disable the Adobe Add-in so I hope I don't continue to have this issue everytime.

share|improve this answer

I could see cell borders in the preview but they did not print. After trying most of the ideas that were suggested, I installed LibreOffice (free, quick, download), opened the spreadsheet, and printed it with no problem.

share|improve this answer

Clear and reset the print area and borders. The borders should now print.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.