Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am on campus LAN. The local LAN (intranet) sites are not opening on my vista system. The internet is working fine. I have a dual boot with fedora. So in fedora everything is working fine ( all sites are opening). So I think error is inside vista system not on network

But if I type the actual IP address (the local IP on the campus lan) then it works. So I think the problem is with DNS. The resolver on my system may be is not able to resolve the address.

Edit 1:

nslookup on my system is giving these messages:(swd.bits-pilani.ac.in (2nd one) is a intranet site)

enter image description here

The problem is: in internet explorer, i have checked the option, "bypass proxy server for local addresses", so typing just "swd" does not work, but "swd.bits-pilani.ac.in" works (it fetches the page through internet rather than intranet). Earlier "swd" also used to work.

But here nslookup only fails on every address

"ipconfig/all" gives the following: ( but I suppose DNS settings are correct since internet works)

enter image description here

Please help in rectifying this problem.

share|improve this question

7 Answers 7

I'm kind of guessing, but is your DNS set to an outside DNS server? It might be that internal resources aren't public facing so they won't show up on public DNS servers. Normally companies, universities... that have lots of internal sites ask that you set the DNS to their DNS server.

share|improve this answer
    
What is the thing that I can do? My friends on my subnet are able to do open all sites. The problem is only with my system. –  pineapple Dec 8 '09 at 13:34
    
Try and check your DNS server settings. Make sure it is set to the same as computers that are working. –  Blackbeagle Dec 8 '09 at 19:14
    
How to set DNS settings in Vista? But I suppose, its correct because internet is working on my system. Without correct DNS settings, even internet would not work. Our DNS server is 172.24.2.71, which is correctly shown by ipconfig/all. So I suppose DNS settings are correct. –  pineapple Dec 9 '09 at 3:57
    
Go Start-Control Panel-Network and Internet-Network and Sharing Center-Manage Network Connections. Look for your connection, right click, properties, click on Internet Protocol ver 4. Look for your primary and secondary DNS servers. Your nslookup query indicated that it can't identify or get to your DNS server. Try and ping your primary and secondary DNS server IP addresses to see if you can get to them. –  Blackbeagle Dec 11 '09 at 4:04

Change your network connection MTU to about 1400.

Pretty good quick way here

Vista does have this problem on the LAN at my house, and may well have it on your campus LAN.

share|improve this answer
    
Its not working for me. Please suggest some other solution. –  pineapple Nov 29 '09 at 4:55

I would suggest running some quick DNS tests. You should be able to do some comparisons between your Vista and Fedora systems using nslookup from the command line:

nslookup intranet.site

This command should provide similar results on both the Fedora and Vista systems. Specifically you will want to look at the Server and the IP address that gets returned for the host you specify as "intranet.site".

share|improve this answer
    
nslookup for all addresses (intranet or internet) is giving me these messages: I have updated in my question –  pineapple Dec 9 '09 at 3:22

you can ADD exptions to your proxy in the advanced section of your lan connections, in internet options.. add the address that you want to bypass your proxy. Good Luck

share|improve this answer

Consider the following:

  • You are behind a firewall. You can't access anything on any network by any means other than through the proxy. That is either in accordance with the firewall policy, or somebody might may be a mistake in the firewall config. (Such things happen.)
  • Your computer does not have to do any DNS lookups by itself when you use a proxy - if you ask the proxy to give you google.com, the name resolution will happen on the proxy.
  • If you have "Bypass proxy server for..." enabled, and make a request for "swd", it still will NOT go through the proxy. And consequently, it will most likely fail. That is in line with what it says in KB262981.

So my advice would be,

  1. check LAN Settings>Advanced>Exceptions,
  2. see if the "mshome.net" domain is actually listed anywhere as a "Connection-specific DNS Suffix" and if so see if it helps to remove it
  3. maybe we're getting confused by all this proxy talk, maybe its just the firewall on your computer that has gotten set too strict. (Check settings of the builtin Windows Firewall and test what happens if you disable it.)
share|improve this answer

DNS is trying to connect with an IPv6 address (fe89:...) and it's timing out. If you disable this and go straight to the IPv4 address (172....) then probably the addresses will resolve properly.

Disabling this in Vista is another story. I avoid Vista like the plague so hopefully another commentor can help out.

Is it receiving these dns server addresses via DHCP? Try typing in the "172..." address manually.

share|improve this answer

I see that "ipconfig/all" shows that IPv6 is on, and is even marked as preferred!

This is wrong, as nobody is yet using IPv6, and certainly not the campus.

To turn it off, follow the directions given here:
Disable and Turn Off IPv6 Support in Vista.

In a nutshell:
Go to Network Connections, right-click your connection and choose Properties, clear the check box next to Internet Protocol version 6 (TCP/IPv6), then OK.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.