Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm the owner of an HP Pavillion tx2120us tablet PC, which has a known problem of making the cursor jump to the lower right corner of the screen.

I've narrowed the problem down to the pen tablet function, since in Vista I was able to turn the tablet input process down, and the problem seemed to go away. It was a simple matter of just opening the task admin and killing the process.

However, as far as I can tell, I can't find the same process in Windows 7, and I have supposedly already turned the tablet functions via "Start" -> "Control Panel" > "Programs and Features" > "Turn Windows features on or off". Yet after a reboot the screen still seems to react to the tablet pen.

How can I finally turn the darned tablet functions off (while still being able to re-enable them in the future)?

EDIT: I have also turned the service off and restarting, as suggested by outsideblasts, to no avail.

share|improve this question
add comment

5 Answers

Go to Services (just windows search it) and see what the status is. Set it to manual or disabled. If it already is disabled then I don't know!

enter image description here

share|improve this answer
    
Thanks and nice try, but windows 7 seems not willing to disable the function (and as I'm typing this, the cursor has clicked on the lower right part of the screen 2 times, taking the focus out of this text box) :( –  Kensai Nov 26 '09 at 1:19
1  
Forgot to mention: restart required! –  outsideblasts Nov 26 '09 at 1:42
    
Yeah, I did. It is now disabled after the restart, but no effect :( –  Kensai Nov 26 '09 at 2:13
    
Since this didn't work, i am going to go ahead and say that the tablet input isn't doing the right thing, and acting like a tablet. Instead it is acting like a mouse; positioning the mouse where you touch. Same is true of generic touch-screen monitors, that are essentially a glorified mouse, rather than a touch screen. Unfortunate. –  Ian Boyd Mar 25 '12 at 13:39
add comment

If you go to "Control Panel" > "Programs and Features" > "Turn Windows features on or off", You can remove the Tablet PC Components.

I know this isn't as easy to turn on later - however, all Windows Vista/7 setup files are stored on your machine, so it should be quick and easy to re-enable at a later date.

alt text

share|improve this answer
    
Sorry I didn't phrase my tried solution correctly (I have now editted it), I have Windows 7 in Spanish. I've actually tried the solution you propose and it didn't work. –  Kensai Nov 25 '09 at 23:49
add comment
up vote 2 down vote accepted

Finally, I found a way! It was a bit elaborate, but it works!

  1. I went to get the wacom driver for tablet PCs, downloaded the driver and installed it.
  2. I opened the task manager (right-click on the task bad on the bottom of the screen -> Task Manager)
  3. I selected the processes tab, and clicked on Show all user processes (I'm roughly translating this from spanish, so this might not be the exact wording) in the bottom left button.
  4. Then looked for both Pen_tablet.exe processes, right-clicked them and selected terminate process (again a rough translation from spanish).

And now the screen does not react to the pen. Free at last!

NOTE: This should apply to all tx2000 and tx2500 series out there, for which the heating causes so many issues.

share|improve this answer
    
For extra measure, you could also disable the input driver related to the touchscreen. –  Dustin G. Jul 14 '11 at 2:09
    
Got one for my wife and started having the heat issues a year later. IT got to the point where I could cause demonstrable hardware failure within 1/2 hour of getting the unit back from service. I annoyed HP enough they finally gave me a completely new model powered by the Intel chip, rather than the AMD. No more overheating, and a much nicer laptop. –  music2myear Aug 3 '11 at 20:38
add comment

You can also turn off the "Tablet PC Components" feature at the command line, by running:

dism /online /disable-feature:TabletPCOC
share|improve this answer
add comment

Described Here are two options, especially for Windows 7 Home Premium users.

The link below shows how to disable a number of irritating Tablet PC functions on windows. It doesn't completely remove the Tablet PC feature though and is intead focused on minimizing the pain of experienced by users of pressure-sensitive tablets on Windows 7.

The first option is a simple tool that automatically makes all the changes.

The second option is a list of manual steps you can perform. In short those steps are:

  1. Install the latest driver: http://wacom.com/en/CustomerCare/Drivers.aspx

  2. Disable the Tablet PC Input Panel. Go here Control Panel > Tablet PC Settings > Other > Tablet PC Input Panel Settings. Uncheck all checkboxes. Press OK.

  3. Disable Flicks. Go here Control Panel > Pen and Touch > Flicks. Uncheck all checkboxes. Press OK.

  4. Disable Press and Hold. Go here Control Panel > Pen and Touch > Pen Options. Select Press and Hold click Settings. Uncheck Enable press and hold for right-clicking. Press OK.

  5. Disable Dynamic Feedback. This requires a registry change because there is no Control Panel UI for this in Windows 7. Go to this regkey [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\TabletPC] and set the value TurnOffPenFeedback to 1. The link has a .REG file you can use.

share|improve this answer
1  
Welcome to Super User! It would be nice to include the essential parts of the answer here, and provide the link only for future reference. Otherwise this answer might be deleted, especially since of the solutions is already explained in the above answer. –  slhck Aug 3 '11 at 20:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.