Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I recently got a new computer running Windows 7, installed the latest version of TightVNC Server (not as a service, just a standalone app that runs on startup).

I'm logging in via an XP box, using the most recent version of the TightVNC client. The login process itself works smoothly, and I can use the computer remotely... for a while. After variable length of time (30 minutes to 2 hours, roughly), the VNC window stops updating, then closes as the computer reboots. Specifically, it drops a socket error message.

After the computer's rebooted, I can connect to the server, but after authentication, VNC freezes in the middle of the initial refresh, then disconnects as the server reboots again.

General advice or suggestions?

Additional info:

After restarting, it does display the 'Windows has encountered an error and had to restart, would you like to let MS know?' window; if I expand the 'More Info' thing on the bottom, I get:

Problem Event Name: BlueScreen OS Version: 6.1.7600.2.0.0.768.3 Locale ID: 1033

plus a bit more identification data that I just lost.

share|improve this question
    
Our school uses TightVNC on Windows XP. It doesn't work well. It makes the computer run slow or freeze, so I think that it is a problem with TightVNC in general. Try some other software. –  benjamin239 Nov 25 '09 at 23:23
    
I've had good results with TightVNC; I used it on my old XP box at home with almost nothing in the way of problems for two-three years, save some fiddling with ports on my router. –  user19287 Nov 25 '09 at 23:39
    
Turn on error reporting, disable the reboot on error, and see if the machine blue-screens. –  user3463 Nov 26 '09 at 14:02

3 Answers 3

up vote 0 down vote accepted

Try RealVNC or UltraVNC and see if it makes a difference.

share|improve this answer
    
Haven't tried RealVNC; did install UltraVNC, but it died on me after about two hours and I haven't been able to reconnect in. –  user19287 Nov 27 '09 at 19:46
    
Got home, found out that it hadn't restarted. This looks like it might be a more workable solution. Thanks! –  user19287 Nov 30 '09 at 17:53
    
Excellent. As specified in Andrei's reply tunneling VNC through SSH is a good idea as VNC is completely unsecured. CopSSH has worked very well for me in the past. –  moshen Dec 2 '09 at 17:01

There was a known problem with the previous version (1.1.68) of DFMirage Driver used by TightVNC on Vista/7. You need to make sure that you installed the latest DFMirage (2.0.105 currently). You can find the most recent version here:

http://www.demoforge.com/dfmirage.htm

share|improve this answer

I try to avoid VNC as it seems too slow for me.

I'd recommend CopSSH + Tunnelier or TeamViewer (portablapps.org)

share|improve this answer
    
The slowdown isn't an issue for me. Have you run Teamviewer in a Win7 environment? –  user19287 Nov 27 '09 at 21:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.