Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu 9.10 from the CD in my desktop, an old intel pentium 4 550 with a nvidia GT 8600 OC graphics card. The installation was smooth and I didn't see any error. I restarted my pc and I can see the login screen, but when I click on my user to login the screen stalls and the login wondow's frame is corrupted. I can click on the rest of the controls there and they work, but when I click on my user to login I get the error. Any ideas?

share|improve this question
up vote 2 down vote accepted

Ideas? Yes! :)

Solutions? Not sure! :(

It might be a compatibility issue between Compiz (desktop compositing manager using OpenGL and installed by default by Karmic) and your graphic card. If this is the case you could try one of the following:

  1. If you have another spare graphic card, try to run your present installation with the other card and see what happens.
  2. Login from command line (ctrl-alt-F2, for example) and remove compiz by typing sudo apt-get remove compiz, hoping that on reboot, this will trigger ubuntu to automatically switch to metacity (the less fancy version of the desktop manager, default on Gnome). Please note that I did not try this myself, and I am not sure if this will actually totally break your installation or not (although you could try to revert damages by typing sudo apt-get install compiz.
  3. Install an earlier version of Ubuntu, like for example 8.04 LTS. See if that works (I believe metacity was the default back then). Then try to install the proprietary drivers for your graphic card and update the system to Karmic.
  4. Use xubuntu instead! Especially on an older machine, xubuntu feels much snappier than ubuntu or kubuntu... and does not use compiz!

Just my two cents... best luck!

share|improve this answer
Thank you for the quick responses. I tried login from the command line ans it worked, so your diagnose was right. I've tried different flavours of ubuntu (ubuntu 9.04, xubuntu 9.10, kubuntu 9.10) and I've only got good feedback with kubuntu 9.10. It looks like the kde desktop works better with my graphics card, but the partitioning tool in this kubuntu distribution is not working very well and I can't progress any further than formatting in the installation. I'm gonna try with older versions of kubuntu and I'll let you know. Thanks for your help!! – user19290 Nov 27 '09 at 11:30
No worries, my pleasure! You could also try the alternate install version of ubuntu/kubuntu/xubuntu. The installer is text-based and with more fine-graned options (or at least so it was the last time I tried it!). The link is: – mac Nov 27 '09 at 16:31

Log in with the "xterm" Sessions option, the run this command

gconftool --type string --set /desktop/gnome/session/required_components/windowmanager metacity

Log out, and log back in under the GNOME session.

share|improve this answer

is it a fresh install? sometimes with over installs or upgrades, the new install gets confused with the old config files it files.

Failing that, try hitting ALt-Shift-F2 and use the text based log in and see if there is any errors.

share|improve this answer

You must log in to answer this question.