Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I upgraded my PC to Windows 7 64 bit Home Premium - clean install. Since then I've tried to install the following SVN clients: Tortois 1.6.6 64bit and 32bit, Tortois 1.6.5 64bit, SlikSVN, SmartSVN, and a couple others. None of them will connect to ANY remote SVN repository.

Note: Everything works correctly when I plug in my old Vista HD with Tortoise 1.6.6 client installed. Therefore, I do not suspect the network per se.

I've seen some posts around with people running into similar issues on Windows 7 64bit but I've yet to see an actual answer/solution to the problem.

share|improve this question

migrated from Nov 26 '09 at 2:47

This question came from our site for system and network administrators.

After turning gaming mode on/off I was seeing inconsistent behavior. I resolved it by opening port 3690 outbound TCP in Windows 7 firewall.

share|improve this answer
I'm finally onto something. I turned on "Gaming" mode in BitDefender Anti-Virus. Re-installed Tortois SVN 64bit v1.6.6 and restarted the machine. SVN connectivity now works. I will respond again after I run the reverse test by turning off the "Gaming" mode to see if I once again get blocked from SVN access. – nopuck4you Nov 29 '09 at 22:21

I know this is a dumb question, but have you checked that your firewall is blocking the ports that your svn clients use?

  • svn:// - Port 3690
  • http:// - Port 80
  • svn+ssh:// - Port 22

I recently did a clean install of Windows 7 Ultimate x64, and had to open a few ports, before I could talk to my Subversion server.

share|improve this answer

check out the post to run SVN in windows 7.

share|improve this answer

I had an issue with running Tortoise 64-bit on one of the Windows 7 64-bit beta builds. Running it in Vista compatibility mode solved the problem.

  • Right Click on the installed Tortoise binary
  • You will get the properties screen, navigate to the compatibility tab as shown here:

    alt text

  • Try running it in compatibility mode for Vista SP2. If it doesn't work, go back a service pack or even back to plain Vista. SP2 worked for me.

share|improve this answer
Tried Windows XP and Vista with no luck. It wasn't just Tortois, it was also SmartSVN and every other SVN client. – nopuck4you Nov 29 '09 at 22:20

For any future cases, I was having the exact same problem, all svn clients I tried failed to connect to my svn server, but I figured out after many days that bitdefender feature of "Antivirus - Real Time Protection" messed with the connection, so I disabled this feature and problem solved. I could connect to my svn server from any svn client I had.

Specifically I was having problems with

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.