Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an odd situation. I have 2 drives in my computer running Vista, the OS drive (C:, E:) and a storage drive (D:). In Disk Management the C: volume is listed as the boot partition and has all of the system files. The D: volume has the "System" flag, but (right now) there's absolutely nothing on it. I'm hesitant about pulling the drive or even repartitioning using a 3rd party tool (since Windows won't let me) as I've read that if a system volume isn't detected Windows can have a conniption. Any ideas?

Edit:

The main reason this is a problem is because Windows won't let me exclude this volume from backups, but it's where I am already storing preliminary backups of other things.

share|improve this question

1 Answer 1

So I got it fixed but it wasn't pretty, and it was probably simpler than I made it out to be (surprise).

I went in and powered down the server and pulled the mislabeled System drive. I tried booting the computer and received "BOOTMGR is missing, Press Ctrl+Alt+Del to reboot". I thought, well that kind of makes sense, let's try a fixboot/fixmbr. After booting the Vista DVD I went into Repair Mode. Usually when you boot into Repair Mode you see an option for Startup Repair, but this wasn't present so I launched a Command Prompt instead.

After digging around I found the fixboot and fixmbr equivalents (bootrec.exe /fixboot and bootrec.exe /fixmbr respectively). I tried one, then the other, then both of those after subsequent reboots to no avail. I googled a few times and found various "workarounds" but nothing fixed it either. After getting thoroughly frustrated I decided to just reinstall Windows since I had a working backup.

During the install process, when selecting the boot partition, if you don't opt to format the partition you are installing to and there is already a Windows folder there it will move the current System folders (Program Files, Users, Windows, etc.) to Windows.old. After the first stage of the install when it goes to reboot to continue installing I had the bright idea of moving those system folders back to their original locations and rebooting again to see if it would pick up like nothing was wrong. The Users folder gave me some trouble copying (some sort of weird infinite loop so I moved the folder of the user account I wanted to preserve).

After copying/moving the files back to their original locations I rebooted and crossed my fingers and wouldn't you know, it actually worked. I was pretty stoked and after doing after-the-fact thinking I realized that there is a bootmgr file on the root partition and that the file was probably physically missing in the first place (like my computer was trying to tell me). I imagine copying that file over and running a fixboot/fixmbr would have probably fixed it faster.

Funnily enough, once I got the computer booting without the spare drive I popped it back in and when I went into Disk Management it listed the spare drive as the System drive again. I pulled it and booted again just to make sure nothing actually changed. After successful boot I put it back in, booted from the Vista DVD again and wiped out that drive. Now everything's fixed. Hooray.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.