Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I do a checkout/update on my SVN project using Tortoise the files all get set to read-only. Is there an option to stop this? I have 1 particular project where I need any checkouts/updates to never make files read-only.


share|improve this question
Are your files becoming read only because they are inheriting the permissions from a parent folder? – user155695 Nov 26 '09 at 10:32
I dont think so if I create some files that are not readonly as soon as I check them in to SVN they become readonly – Gavin Nov 26 '09 at 10:36
Do your files have the svn:needs-lock property set in the repository? See, section on Lock Communication. – jrb Nov 26 '09 at 16:29
I think they do, would runing this off fix the problem? – Gavin Nov 26 '09 at 17:08
I've just checked and I dont think they do have this property, but could be wrong whats the best way to be sure? – Gavin Nov 26 '09 at 17:11

Looks like your files has svn:needs-lock set. To check this, select TortoiseSVN -> Properties context menu on any locked file. See for more information.

Also, it looks like you have Automatic property setting, that set needs-lock on all new committed files automatically. Select TortoiseSVN->Settings, General tab, click Edit button to see subversion configuration file. See, if enable-auto-props = yes string is uncommented, and if there are some uncommented lines in [auto-props] section.

Or probably you have project properties set on some parent folder (e.g., trunk) as recursive. To check this, select TortoiseSVN -> Properties on project parent folders.

See for more information.

share|improve this answer

I had this problem with a tool we use at work to use SVN as a Microsoft SCC provider (Provided by PushOK Software). It ran in the background and did things like this, which was extremely annoying. Once this was turned off the read-only issue never came up again.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.