Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am setting up a VPN connection for the first time. I am working on a project in which i would like to access my LAN at my home from the outside world. So, I installed OpenVPN2.2.2 on my 32-bit Windows 7 laptop (acting as the server). My end goal is to load a page which is accessible only on my local network.

I created a client certificate which is 64-bit Windows 8 laptop (with OpenVPN2.2.2 installed on it). I am able to connect to the server through VPN using my client. I can see that green gui icon in system tray bar in both the laptops. I also see the "Initialization Sequence Completed" in the logs with no major errors. However, when i try to ping any of my devices within the LAN, i am not able to do it using my remote client running openVPN. Also, when i look for ip using, I still get the client's original IP address and not my LAN's IP.

These are the major warning/notesthat i have received.


NOTE: your local LAN uses the extremely common subnet address 192.168.0.x or 192.168.1.x. Be aware that this might create routing conflicts if you connect to the VPN server from public locations such as internet cafes that use the same subnet.

Warning: route gateway is not reachable on any active network adapters:

MULTI: bad source address from client [], packet dropped


WARNING: potential route subnet conflict between local LAN [] and remote VPN []

I have been doing a lot of research on this for past week. I looked into openVPN documentation and forums. People are able to connect to the servers, but are not able to ping. These are the additional steps i have taken:

  • disabled my windows firewall completely (both on client and server) for addressing that TUN/TAP interface issue
  • setup port forwarding, so whatever connections are made to my router at port 1194 are forwarded to my server (with a static-ip of
  • running everything with admin rights
  • configured Routing and Remote Access in Windows machine (server)
  • IPEnableRouter is 1.
  • Checked the box for "Allow other network users to connect through this computer's Internet connection for TAP adapter.

Some more steps that I undertook after obtaining them from openVPN forums:


port 1194
proto udp
dev tun
ca "C:\\Program Files\\OpenVPN\\config\\ca.crt"
cert "C:\\Program Files\\OpenVPN\\config\\server.crt"
key "C:\\Program Files\\OpenVPN\\config\\server.key"
dh "C:\\Program Files\\OpenVPN\\config\\dh1024.pem"
ifconfig-pool-persist ipp.txt
push "redirect-gateway def1 bypass-dhcp"
push "dhcp-option DNS"
push "route"
keepalive 10 120
status openvpn-status.log
verb 5


dev tun
proto udp
remote 1194
resolv-retry infinite
ca "C:\\Program Files (x86)\\OpenVPN\\config\\ca.crt"
cert "C:\\Program Files (x86)\\OpenVPN\\config\\client1.crt"
key "C:\\Program Files (x86)\\OpenVPN\\config\\client1.key"
ns-cert-type server
verb 3
explicit-exit-notify 2
ping 10
ping-restart 60
route-method exe
route-delay 2

If you could help me troubleshoot this problem, it would be really great. Any hints/suggestions are extremely welcome. Thanks.


Thanks a lot for your suggestions.

1) Could you please explain a little bit what exactly do you mean by "getting a firewall or if you have on using your firewall to VPN"? I already have the built-in firewalls in both my client and server, and i disabled them both, just so they don't interfere with my setup for the time being.

2) I did change my ip address subnet. So the default gateway on my server side is now instead of will hide my IP address. :D

3) is the default gateway for TAP-Win32 adapter. So, after looking in openvpn forums, I added as the default gateway on my server side by going into advaced settings IPv4 Properties of TAP-Win32 adapter. To be honest, i don't know why i did it. I was just desperate to get it working.

Now, since i changed the IP Subnet of my route to, I am only seeing two warnings in log files, which is real good news IMO. But I still can't ping (need to look into ping policies too, but i doubt if it could be the problem). Also the client side have zero access to internet when connected to my server. No ping, No web pages, No internet.

Server Side warning says:

Warning: route gateway is not reachable on any active network adapters:

Client side warning:

WARNING: potential route subnet conflict between local LAN [] and remote VPN []

Thanks a lot again.

share|improve this question

migrated from May 20 '14 at 5:09

This question came from our site for system and network administrators.

You would be far better off using a tap interface if you want bidirectional access between your local machines and your VPN client with the least effort. – qasdfdsaq Jul 7 '15 at 14:51
up vote 0 down vote accepted

I would suggest getting a firewall or if you have one using your firewall to VPN. I have watchguard and it is very simple to make or edit policies, such as ping. I had an issue where I did not want users on sub-net "B" to even be able to ping sub-net "A" and easily changed that in that policy.

Anyway you could try changing the sub-net of your network (if possible) having a "normal" IP range as is not the best practices method. I also would not put your external IP address for the world to see :)

To me it sounds like something in your firewall is not routing traffic to your 192.x.x.x sub-net and from the looks of it, its because your LANs have the same IP range. Also what device do you have on looks like your gateway but your LANs are different. Please explain a little more...

P.S. sorry i tried to comment instead of answer but i dont have enough rep.

share|improve this answer
Thanks a lot for your suggestions. – numbersinmyhead May 20 '14 at 16:26
I edited my post to communicate with you. I am unable to say everything here. It will be really nice of you, if you could make some more suggestions. Thanks!! – numbersinmyhead May 20 '14 at 16:41
What i meant by firewall is having a firebox or sonicwall as a gateway to your network. easy to use VPN access. anyway how is your network set up? such as router, switches? what exactly is your gateway @ Without running vpn can you access ping, internet, ect on both systems? just trying to make sure your LAN networks are correctly set up on both ends before connecting together. – Vdub May 20 '14 at 18:02
the server is setup on my home network. I live in a house & has the IP assigned by the ISP. I believe I have a cable modem which is then connected to my router (port fwdng enabled). Router is just WRT160N Linksys. The ip address of that router is (before I don't have any switches involved. Server(windows 7) is connected with the router wirelessly. The client is on my friends's house who lives in a different house and has a different ISP. So, he connects to my laptop using openVPN. Both of us disabled our firewalls. OpenVPN assigned it the IP of – numbersinmyhead May 20 '14 at 19:00
i have internet enabled on both the networks without the VPN. But my friend's laptop ceases to connect once the VPN client is connected to my server. My server works perfectly fine wihout any trouble. WOuld you want me to post some more logs from iptables or tracert? – numbersinmyhead May 20 '14 at 19:04

This statement

 push "route"

in the server.conf file is the origin of your problems. The

push "route ..." 

statement, not to be confused with the

push route ... 

statement which performs a different function, is used to inform OpenVPN clients of the existence of a LAN behind the OpenVPN server. Since you changed this subnet to, the above statement should be changed to:

  push "route"

You can find the description of this statement in the OpenVPN Howto. Besides detailing what I already told you, you will also find the followng statement:

Next, you must set up a route on the server-side LAN gateway to route the VPN client subnet ( to the OpenVPN server (this is only necessary if the OpenVPN server and the LAN gateway are different machines).

Make sure that you've enabled IP and TUN/TAP forwarding on the OpenVPN server machine.

Both of these operations are crucial to the working of the OpenVPN, Unfortunately, they are also OS-dependent, so that you will have to figure out how to do it by yourself.

Users on Linux machines would need the following two commands:

   ip route add via IP.of.TheOpenVPN.Server
   echo 1 > /proc/sys/net/ipv4/ip_forward
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.