Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Having issues with IE11 opening on a newly built Windows 7 laptop. Laptop model is a Lenovo T431s.

IE is working fine on LAN.

When connected on WLAN it can take up to 25 seconds for Internet Explorer to open - after clicking on the icon. It is also slow switching between tabs.

I have connected to several different wifi networks and still face the same issue (ruling out an issue with the access point).

I can connect to the wireless networks fine. I can then ping 8.8.8.8 fine. The delay seems to be opening the IE application. Pinging works fine - whilst waiting 25 seconds for IE to open.

I have tried several fixes relating to this, but all seem to be to no avail:

  • Reset all IE defaults and clearing caches
  • Disable Add-ons and Accelerators
  • Changing the homepage
  • Unticking AutoDetect settings within LAN config settings
  • Clearing the 'Use software rendering instead of GPU rendering' box under Advanced settings
  • Updating my wireless driver

Opening IE (No-Add-ons) through the Accessories > Systems Tools submenu also takes time to load. I noticed when using this, that more add-ons were enabled. I also disabled these - but it still made no positive impact.

Google Chrome is working fine.

share|improve this question
    
When you say it works fine on LAN what do you meant exactly? –  Ramhound May 20 at 12:54
    
Can you try using 8.8.8.8 for the DNS just to test if it makes any difference... I don't think it will, but it's nice to rule things out. Also, and sorry to ask, but did you try this on multiple sites? –  Dave May 20 at 12:56
    
What's the laptop model? What's the IE version displayed in the about dialog? Try creating a new user account, and check if you get the same issues there. –  and31415 May 20 at 13:00
    
Have you previously connected to a wireless network that uses a captive portal... I'm thinking there is a cached WPAD configuration that's still causing IE to work out what settings it needs to connect. –  Big Chris May 20 at 13:02
    
@Ramhound IE works fine on LAN. No delays in opening IE - i.e, you click the icon, and it opens instantaneously. –  Alex May 20 at 13:26

1 Answer 1

The issue could be related to your WLAN settings on the router side. If your wireless network has devices connecting to it that are less than 3 years old, then you can set your router to broadcast at N only speeds (as opposed to b/g/n). Also be sure to set your encryption level to WPS2 with AES, not TKIP. Also the narrow band (HT20) should be used and the transmit power for the radio antenna should be set to high. Another thing to check would be the channel you're broadcasting on. Install a WiFi scanner on your smartphone to see if there is channel congestion on your wireless broadcast channel. If so, manually set the channel to one with less traffic. I hope this helps.

share|improve this answer
    
Hi Eric, thanks for your feedback. I have connected to various wi-fi points so I don't think the WLAN is the issue. We have an estate of 250+ laptops - all of which use these wireless routers on a day to day basis, and none of them are having issues. We do extensive testing on a regular basis regarding channels using inssider. Thanks, Alex –  Alex May 20 at 13:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.