Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When Using MS Remote Desktop 8.0.x to connect from my Mac to a Windows VM on another host I have a key mapping problem.

Windows treats the Mac's arrow keys as if they were on the numeric keypad (which this keyboard doesn't have) and the number lock was on. The result is that when I use the arrow keys they act as keypresses on the numeric keypad rather than moving the cursor around.

In the following image, I've edited in the effective number mappings:

Something Odd

  • This issue happens only with this one particular RDP host.
    • I am not experiencing this problem with other hosts (I have about a half dozen I connect to)
  • This issue happens only with MS Remote Desktop 8.0.x (presently 8.0.6) on OSX.
    • I have confirmed that CoRD 0.5.7 maps the keys correctly.
    • I connected with an MS RDP client from another Win7 box and the arrow keys functioned fine (though that box had a normal keyboard with numberpad as well).

I tested using the Windows on-screen keyboard to turn numlock off in the RDP session. As soon as I pressed an arrow key after that, numlock came back on and the arrow keys continued to function as if they were number keys.

This problem magically materialised one day (sorry can't remember exactly what version of RDP I had at the time but it was 8.0.something).

The RDP target is a Win7 VM running on VirtualBox 4.3.10 on an Ubuntu 14.04 host. I am connecting to the RDP host in the VirtualBox hypervisor rather than directly to Windows due to the fact that the Windows guest is Home Premium and thus doesn't support inbound RDP connections.

Can anyone suggest how to get the OSX arrow keys to be treated as arrow keys within the RDP session like they are everywhere else?

share|improve this question
    
Dang it, I have the same problem on Yosemite, VBox 4.3.20r96996 and 8.0.12 of Microsoft RDP client –  Jamgold Jan 20 at 17:53
1  
I just found royaltsx.com/main/home/osx.aspx which works better than CoRD for me and doesn't have the problem MRDP has –  Jamgold Jan 20 at 18:31

3 Answers 3

This is a confirmed bug in VirtualBox 4.3.8 but should of been fixed in 4.3.10. You may want to try an older version or the "test" version in the first link.

share|improve this answer
    
interesting. Would this issue allow for the fact that it's the specific combo of MSRDP on OSX hitting this particluar VM that has this issue? –  LRE May 21 '14 at 22:23
    
This issue happens to me in VirtualBox 4.2.4 –  lkraider Feb 7 at 3:49

I am also having the same issue. MacOS (10.9.5) RDP (8.0.13 Build 25377) VirtualBox (4.3.20r96996) running on Ubuntu 12.04 Host with a RHEL5 guest running in fullscreen.

For me it is triggered by hitting the caps lock or the num lock keys.

Using EkriirkE's tip, I am able to get the arrow keys back by toggling num-lock back off. (Using a real keyboard on the linux box or an onscreen keyboard, and then the arrow keys work, but only on the real keyboard). It will get stuck again if I use any key in RDP just like LRE said, unless I close the RDP session (Command-Q or Command-W) and then reconnect the RDP session.

So in summary, my workaround:

  1. Toggle Num lock off in the VM (in linux I can use the command numlockx off)
  2. Close the RDP session ⌘Q or ⌘W (you must do this before sending any more keystrokes to the VM)
  3. Reconnect to the RDP Session

This will reset the num lock states in both the VM, and the poorly synced state in RDP.

  • A more automated fix would have an AutoHotKey script, or Bash script turn off num lock when you reconnect before you type in any keys remotely.
  • You could also just never use CapsLock / NumLock or disable them for RDP.
share|improve this answer

Can you try using the OnScreen keyboard (OSK) on the remote machine (Accessories,Accessibility) And toggle the num lock key and try again? I've had this issue with Linux+Windows RDP, however my linux machine has an actual num lock I just have to toggle a couple times to sync the state, where the mac missing one created a second problem- the OSK should work.

share|improve this answer
    
tried that: as soon as I pressed one of the arrow keys, the num lock on the OSK turned itself back on. Have mentioned it in the paragraph just below the bullet points. –  LRE May 21 '14 at 4:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.