Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 8.1 machine that was working perfectly fine up until tonight.

I went out and bought a Chromecast so I could be a bit more productive in my coding (cast the web page with the programming information I need up onto the TV and use my entire laptop screen for the IDE), and, well, that's gone to waste. Like you're supposed to, I went to Google's website and downloaded the program to connect to the Chromecast and set it up. I ran it, and when I got to the part of the setup where you have to connect to the network, I couldn't get it to work. I then switched over to my Android tablet and... ta-da... it worked. The Chromecast was able to connect to the network and I was able to cast tabs to it from my laptop.

I lost my internet connection on my laptop sometime thereafter. Now, no matter how many times I restart my computer, tell it to forget the network it was on, sign back in (password and all) to the network, "reset" the network adapter, or unplug/plug the router or modem... it won't connect. What's up here and how do I fix it? Other devices still connect fine.

share|improve this question

2 Answers 2

Wow, I had a similar problem but my network adapter was enabled. For fun, I disabled it and then enabled it. Everything when back to normal.

Something must have gotten flushed out.

share|improve this answer
  1. Go to Control Panel
  2. Click on Network and Sharing Center
  3. Click on "Change Adapter Settings" on the left side of the window.
  4. If any network adapters are disabled, re-enable them.

It's a weird situation and while it works, it's specific to my machine (Lenovo Yoga 2 Pro) and I have no idea why a virtual network switch was disabled. Oh well, there you have it. Maybe this will help someone else someday.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.