Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

It all started this morning when I tried to open a C# solution I'm working on for quite some time now. Right after loading the solution I got the error: "vhost.exe has stopped working". Since then I've been trying to figure out what was going on. I started to uninstall things, like resharper and other add-ons, but the problem persisted. The next thing I did was to repair VS2008 but it didn't work either, then I completely removed and reinstalled it but nothing changed. I've even reinstalled the .Net Framework again but to no avail. At this time of the night, and having almost wiped my hard disk from games, applications, services and whatnot, it keeps crashing with the message "xxx has stopped working". The only thing I've found is that only .NET applications (as in managed) seems to be affected by this problem.

Any ideas of what could be causing this?

You guys are my only hope before I have to give up and reinstall everything from scratch (and rolling back to XP).

Note: I've also been reading info from logs and system events looking for detailed information but everything was too "low level". Not a single reference to missing files nor corrupted data.

Note: I forgot to mention that applications crash outside the VS2008 IDE also so I don't think it has nothing to do with it (at first glance).

share|improve this question
up vote 3 down vote accepted

This doesn't directly answer your question, but that process vhost.exe is only running because your solution's default project's Debug properties include the "Enable the Visual Studio hosting process" option.

Enable the Visual Studio hosting process

Select this check box to enable the Visual Studio hosting process. This option is selected by default.

In order for debugging in a security zone to work, this option, as well as Debug this application with the selected permission set, available from the Advanced Security Settings Dialog Box, must be enabled.

This is not a common requirement (although, maybe it should be). Thus, if you uncheck that option from the projects in your solution vhost.exe will not be built and run by Visual Studio on your behalf.

share|improve this answer

I am having exactly the same issue. All .net applications on my Vista machine have mysteriously stopped working. The all fail with "xxx has stopped working". This happens regardless of whether or not I run it in visual studio. I've tried reinstalling the .net framework, rolling back to an older system checkpoint, repairing the OS. Nothing has worked.

share|improve this answer

See Uninstalling .NET Framework 3.5 SP1, as to how to totally uninstall and reinstall
.NET Framework 3.5 SP1.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .