Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm remoting into a windows7 machine with RDP over the internet, and when I try to log into the router (using IE8, Firefox or TELNET), he prompt keep acting like I've typed a wrong user/password.

the only way to login is to be there, locally .

is it part of security restriction ? or something i should configure ?

EDIT

the password is lower case characters only, -Im able to login locally- , and I've make sure there is no keyboard layout differences, no CAPS, no NumLock. Ive even tried with the On-Screen-Keyboard.

the password is correct.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

If you are connected to a RDP session and are connecting to the router from there, it should act the same as if you are connecting to the router from that machine.

I have not seen a router intelligent enough to know if a client is coming from a console session or remote, and if it could, it would be a real security threat if this sort of information was available to websites.

So, perhaps you do just have the wrong password? If not, it is possible that there are other errors. Can you 100% log on to the router using the same password from the client machine?

Lastly, careful for symbols and keyboard differences there may be between guest and host for example @ (At symbol) and " (quotation marks) amongst others. You may want to try typing the password into notepad or any text field then copying and pasting in to the correct place (You cannot usually. (If you cannot right click paste, remember Ctrl+V)

share|improve this answer
1  
+1 I have this problem all the time (usually through VNC, but same idea). The user has CAPS lock on, the remote computer is typing the wrong slash, etc. –  Stephen Jennings Nov 27 '09 at 3:35
    
the password is lower case characters only, -Im able to login locally- , and I've make sure there is no keyboard layout differences, no CAPS, no NumLock. Ive even tried with the On-Screen-Keyboard and your ctrl-v stuff. the password is correct. –  Revolter Nov 27 '09 at 3:48
    
over RDP the Caps-lock behaviour is at of client side setting,so if the system you're logging into has CAPS lock on and the system you're on has CAPS lock off, the password will be transmitted with CAPS lock on. Try switching ON Caps lock on your local system and try –  Sathya Nov 27 '09 at 4:05
    
weird, now I can login using TELNET but not with HTTP –  Revolter Nov 27 '09 at 8:28
    
This is really just unfortunate timing and the problem is related to something else - As I said, it should not make a difference if you are connected over RDP as the connection to the router is coming from the correct machine - only time this wouldn't be true is if you wrote RDP but meant VPN... However, I don't think this is the cas. –  William Hilsum Nov 27 '09 at 8:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.