Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have upgraded my Ubuntu desktop machine from Hardy to Intrepid to Jaunty and now to Karmic.

My notifications still use the old Hardy (or maybe Intrepid) theme. Ie. The notification window is yellow, whereas with a fresh install of Karmic or Jaunty, the notification windows are black.

I like the new theme. Is there a way I can experience the new theme?

I found an application called notification-properties. There are two themes to choose from, "Standard theme", and "Ubuntu Theme". Neither of them are the new black theme.

share|improve this question

I always do fresh reinstalls, so I did not do the following myself, but I imagine that you could follow these steps:

$sudo apt-get install notify-osd notify-osd-icons #install the new way
$killall notification-daemon #kills (stop running) the old way
$notify-osd #runs the new way.

If it works and you are pleased with the result, you could make the change permanent (and easily reversible) by making a file with lines 2-3 from above in it, then making it executable (right-click > properties > permissions > Allow executing...), then adding this file to the list of files which get ran automatically when you log in (System > Preferences > Startup applications).

There are other ways to make the change permanent by editing the scripts in etc/init.d but as I do not have an old installation, I would not be able to guide you through.

Hope this helps!

PS: For getting the best out of the new notification system, you should enable compiz!

share|improve this answer
notify-osd was already installed. Not running tho'. For some reason the executable is in /usr/lib/notify-osd. Ran that. Went to kill notification-daemon - but it wasn't running. Now I get no notifications at all. Every upgrade has had similar hiccups unfortunately. Might try again later. – Joel Nov 28 '09 at 15:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.