Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In the Control Panel\Network and Internet\Network Connections, I have a Wireless Network Connection. When I right-click on it, a properties dialog opens. Now, I need to change the IP address for TCP/IPv4. But the Properties button is disabled.

I tried following commands:

  • netsh int ip reset
  • netsh winsock reset
  • netsh interface IPV4 uninstall
  • netsh interface IPV4 install

but did not help.

My issue resembles this question, but I m not sure it is due to DHCP configuration of my ISP provider. Because the internet is working on another computer.

Thanks in advance!

share|improve this question

4 Answers 4

I assume you've tried restarting your computer and router, but try

"netsh ipv4 reset", "netsh ipv6 reset", "ipconfig /release", "ipconfig /renew", and "ipconfig /flushdns"

THEN restart your computer.

If that doesn't work, then refer to this thread:

As it suggests a malware infestation of the "c:\windows\system32\drivers\tcpip.sys" file

share|improve this answer

I had the same problem and I found the solution (source) by disabling a service called datamngr

It is most probably is caused by AdWare so you should run AdwCleaner

To resolve the problem:

  1. Click on start type msconfig then go to Services tab and find Datamngr Coordinator
  2. Uncheck it select OK and then reboot your PC.
  3. Now IPv4 and IPv6 properties should be enabled.
share|improve this answer

I have the same problem with build 10049. No way to set up any static IP.

However I used the following solution: Manually assigned IP address in your router DHCP server for the MAC address of your computer network adapter.


share|improve this answer
This sounds like a nice workaround, but reading the other answers I wonder if this doesn't hide the cause, which apparently might be that IPv6 is on and supported, or worse: malware? So, did you read the link from dadda7860's answer? – Arjan Apr 18 at 9:55
I assume this answer is about Windows 10. In that case, it doesn’t apply here. Also, this “workaround” (if you even call it that) is simply pointless. There are more (important) settings hidden in that menu. – Daniel B Oct 24 at 19:25

install malwarebytes free version or other software to remove the malware from your computer run the software to clean the malware on the computer - restart computer after finish cleaning the malware.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.