Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got an ASUS K70AB Windows 7 laptop. It was in storage for over a year because a couple keys broke off and the power charger was lost.

I installed a new keyboard (very simple to pop out the old one and put in the new, no deep-diving nut & bolt extraction required) . . . and got a new power charger.

The first couple boots seemed fine as I was doing all the Windows updates. Then later that day after it went into hibernation mode, I pushed the power button, but the screen stayed black.

I've since rebooted it about 70 times, and roughly 3 of those times I actually got a display.

Within 2 seconds of pushing the power button I can tell if it will work, because the Caps Lock, Num Lock and Scroll Lock buttons blink.

If those 3 buttons didnt blink right away, even giving it 10 minutes, nothing happens.

I've tried swapping the 2 RAM chips around and 1 at a time... no difference.

I've tried hooking my laptop up to a working monitor... monitor stays black just like the laptop screen.

I dont think its booting to windows, because if it did, the caps lock key would turn the caps lock light on. The fan does not turn on either.

Any ideas?

Thanks,

share|improve this question
    
It sounds like the laptop may be many years old. The CMOS battery may be dead and that can sometimes manifest in odd ways. It is inexpensive to replace and could be needed even if it isn't the cause of this problem. It's a quick, cheap fix to try. –  fixer1234 Feb 7 at 18:58

1 Answer 1

I think it may have the same problem as mine. Try my way to turn it on,mine opens every time like this: 1.Power on 2.Wait with black screen approximately 30-40 minutes 3.Power off and power on immediately,it should display boot screen if it has the same problem

share|improve this answer
    
If your computer is more than a few years old, see if replacing the CMOS battery fixes it. –  fixer1234 Feb 7 at 19:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.