Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Background Information / Computer Specs

I have a 14-inch Samsung Series 5 Ultra. Core i5 CPU, 750GB HDD, 8GB RAM, Intel HD Graphics 4000. I've had the computer for about 1.5 years with no major problems.

Problem

The issue appeared at the beginning of April this year, when I updated the OS from Windows 8.1 to Windows 8.1 Update 1 (not from 8 to 8.1). After being on continually (except for at night, when I put it on sleep mode) for about 48 hours, the disk usage as seen by Task Manager hits 100%. When this happens, everything from opening/closing applications to typing and even bringing up the start screen by pressing the Windows key becomes extremely slow. The only way to make the disk usage decrease is to restart the computer. Then the problem repeats. I've used my current laptop (as well as my previous laptops) this way -- putting it on sleep mode at night and restarting it only when Windows needs to install updates -- for a long time. So I know the 100% disk usage is not due to the way I use the computer.

The thing that causes the spike varies. Sometimes it's System, sometimes it's one of the various applications I installed (e.g. Chrome, Evernote, Spotify, Wunderlist, iTunes, etc.), and sometimes it's Antimalware Service Executable, etc.

Tried Solutions

I think I tried almost every solution out there for this problem:

  • Running the check disk command (chkdsk /b /f /v /scan c:) from Admin Command Prompt
  • Running Windows Memory Diagnostic
  • Disabling Superfetch and Windows Search from services.msc
  • Running "Fix problems with Windows Update" from Control Panel --> Troubleshooting
  • Updating and rolling back the graphics driver (Intel HD 4000)
  • Disabling "Use hardware acceleration when available" from Chrome settings
  • Disabling Intel Rapid Storage Technology
  • Running the SFC /SCANNOW command as recommended here
  • Running a quick scan & a full scan from Windows Defender (no threats found)
  • Taking the hard drive out and putting it back
  • Refreshing the computer, from the Update and recovery --> Recovery option in Windows settings

NONE of the above worked for me. I was about to give up but then noticed that one of the main culprits of the disk usage spike, as shown in the "Disk Activity" section of the Resource Monitor, was C:\System (pagefile.sys). I googled around and found that one of the recommended solutions was to disable pagefile. I then went to Control Panel --> System and Security --> System --> Advanced system settings --> Advanced tab --> Performance settings --> Advanced tab --> "Change" under Virtual memory and discovered that the number for "Currently allocated" at the bottom was 1280MB, although the number for "Recommended" was 4533MB. I immediately changed it to 4533MB and checked my family members' computers to see what the numbers were like. All of theirs had a currently allocated space that was only slightly smaller than the recommended space. See screenshot below:

Virtual Memory Settings Page

This might fix the problem. I'll have to wait a couple more days.But if it doesn't, what in the world should I do next? I'm guessing the hard drive isn't failing because

  1. This computer is less than 2 years old; and
  2. Speccy says that the status of the HDD is good.

Update 5/27/2014

The "4533MB" solution did not work. I had to reboot the computer about 30 minutes ago because the disk usage again hit 100%. When I opened Resource Monitor the C:\System (pagefile.sys) again was shown to be the culprit. I have now disabled pagefile entirely via the same window shown above in the screenshot. The number for "currently allocated" is now 0MB. Will update again in a couple days, or if the problem occurs again, whichever comes sooner.

Update 6/4/2014 (Disabling page file force-restarts the computer)

So, between 5/27 and 5/30 I had to restart my computer for reasons related to various updates for third-party applications. I used my laptop (unplugged; on battery) on the night of 5/30 and then put it to sleep mode over night. When I woke up on 6/1 and pressed the power button, it first seemed like it was resuming from sleep but then rebooted the computer. This morning, the computer rebooted again. I guess disabling pagefile entirely took a toll on my RAM? I don't really know how to interpret this. For now I've enabled pagefile again.

Good News/Bad News Update 6/5/2014

I think I figured out the source of the problem - it's Superfetch. I think it has been Superfetch the whole time. It's true that I did include "disabling superfetch" from services.msc in the "tried solutions" list above. What I didn't realize at the time was that Superfetch restarts itself automatically shortly after I turn it off and disable it. So, the question I now have is: how do I permanently disable Superfetch?

Probably Final Update 6/8/2014

I think I figured it out. It probably was Superfetch the whole time. On the night of 6/5, after being on continually for a day, the disk usage started to spike again. I went to services.msc and stopped & disabled Superfetch. The disk usage got restored. About an hour later, I reopened services.msc, checked the status of Superfetch, and found that it was enabled again. I did this "disable-it-and-it-got-enabled-again" thing at least 8 more times, to no avail. I then googled "how to disable Superfetch permanently", and tried disabling Superfetch via 1) the administrator command prompt; 2) the registry; 3) services.msc, but nothing worked.

Then I went to this webpage and tried the "Disable Prefetch" option in the registry. I set both EnablePrefetcher and EnableSuperfetch to have the value data of 0. Superfetch was still running, but 3 days after I did this, my laptop has not seen a single disk spike. I put it to sleep mode overnight, and it did not force-restart in the morning.

For those of you having the same problem, please try the "Disable Prefetch" option as described on the webpage.

share|improve this question
    
You could try checking the system files "offline" using a WinPE disk and DISM to try to restore various things. answers.microsoft.com/en-us/windows/forum/windows_8-system/… –  Big Chris May 27 at 6:51
    
@BigChris Hmm... where in the post does it talk about how to use a WinPE disk? –  Gookjin Jeong May 28 at 1:37
    
I had got the same problem yesterday and I called the technician. He disabled three services Windows Search, Windows Update and Superfetch. He then restarted the PC and the disk usage went back to 1-6%. Maybe that could help you. –  Sri Harsha Chilakapati May 28 at 2:15
    
Sorry, I should have added that by using a WinPE disk you can boot to CD and then DISM can perform many tasks on your Windows 8.1 install whilst it is not being used ("offline"). It can also be used "online" but when Windows is online many files and services are in use so some of the error checking might not entirely be successful. I put the URL up as a resource for some of the commands to try. Sorry for the confusion. –  Big Chris May 28 at 6:24
    
@BigChris I did a very cursory read-through of the instructions and it seems like that'll involve a lot of complicated steps. Could you explain how doing that will attempt to solve the problem? –  Gookjin Jeong Jun 4 at 15:23

4 Answers 4

Here's what I did to solve the problem: disable Prefetch and Superfetch in the registry.

Go to regedit, and navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters. Double-click on EnablePrefetcher and change the value data to 0. Double-click EnableSuperfetch and change the value data to 0.

Regedit Prefetch and Superfetch

share|improve this answer

How much free space do you have?

And I believe you're referring to disk active time being 100% not space used right?

To identify what activity is causing the high disk load, open up Resource Monitor and go to the Disk tab > Disk Activity and sort by the Total Bytes/Sec (highest first). Then look at what files are actively in use. You may find it's your antivirus doing a scan, or it's Windows search doing some indexing, etc... then you can work back from there. I'm not convinced that super fetch is your problem. You can also sort by Read / Write bytes to see if anything stands out as the culprit.

Also you should let Windows manage your page size for you, tweaking these kinds of settings aren't going to help you. First identify the files being access during the high disk active time, not just the process... System is much too generic and used for all kinds of local services. By seeing what files are being accessed you'll be closer to solving your mystery.

Good luck!

share|improve this answer
    
I've already tried this - but I figured out that it was Superfetch. Read Update 5/27/2014 in my question for details. –  Gookjin Jeong Jun 6 at 16:27
    
You don't put any details on how you conclude it's superfetch though. What files do you see it accessing? What's your disk space look like? –  AckSynFool Jun 6 at 19:34
    
On the C drive I have 394GB free of 673GB. Yeah, Superfetch (or SysMain) might not have been the problem, but there was something I tried that worked. I'll put this in the update for my main post for everyone to see. –  Gookjin Jeong Jun 8 at 18:16
    
This is not root cause analysis, this is just disabling system services to "fix" your issue. The underlying file access issue is still there and you are justifying fixing it by disabling an otherwise very useful memory optimization feature (Superfetch). Fail. –  AckSynFool Jun 10 at 3:56
    
1) Superfetch is still running on my laptop; modifying the registry as detailed in my solution did not disable the service. 2) I'm not "justifying" anything even in the loosest sense of the term. I came up with a method that worked for me. 3) Why don't you actually suggest an alternative solution rather than criticize how what I did was not "root cause analysis"? –  Gookjin Jeong Jun 10 at 6:41
up vote 0 down vote accepted

So, truth be told, I did not have any luck with the previous solution I posted for this question. I tried a lot of other things, and the thing that conclusively worked for me was the combination of Disabling Hibernation and Turning Off the Pagefile. Try this and I guarantee that this will work if you're having the pagefile disk usage problem.

share|improve this answer

On my Win 8.1 laptop, the issue seemed to be MsMpEng.exe (Windows Defender/Antivirus) when running Malwarebytes at the same time. Here is related post on SuperUser.com on to remove or turn off MsMpEng.exe.: Disabling Microsoft Antimalware service

I discovered this in ResourceMonitor (the disk tab, the "disk activity" section) after turning off several features as discussed in this post. I saw dozens if not hundreds of MsMpEng.exe tasks read/writing the disk at the same time.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.