Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Ubuntu 12.04 server.

Each time, after logging in, I am asked for the SSH passphrase. I would like to disable SSH on boot, just to use it when I actually need and I have tried different things, but nothing have worked so far.

share|improve this question
    
On each login? SSH is used to login from a machine to another. Can you explain better what happens? – Hastur May 27 '14 at 13:02
    
Yes, sorry. I start the PC and after asking me user and password, it asks for the SSH passphrase. – amp May 27 '14 at 13:03
    
Does it happens only at the first login or even each time you open a new shell? Did you connect in a text or graphical environment? After that you logged and insert the password the first time what happens if you press CTRL+ALT+F2 and you log again? Do you work on the PC on which you log or you work on a different computer via that PC? – Hastur May 27 '14 at 13:12
    
I am using a text environment. It asks for the passphrase only the first time. I am working on the PC I log in. – amp May 27 '14 at 13:28
    
Try to press ctrl z when it asks for the ssh password, and see where are you (in which script). PS>Did you recently generate ssh key to do automatic login via ssh to remote computers? Because if you did you might need to give a password now to access your private key file, but you should not need to give the password to ssh. – Hastur May 27 '14 at 13:35

Set the default runlevels to on

sudo update-rc.d ssh enable

Sets all to off

sudo update-rc.d ssh disable # sets all to off

Remove the service from startup

sudo update-rc.d -f ssh remove

Reset it

sudo update-rc.d ssh defaults
share|improve this answer

run this on the terminal:

gnome-session-properties

you will see this:

ssh key on ubuntu startop

then just remove the ssh key agent from the list

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .