Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having major problems with my iPod Touch. The story so far...

I had it connected to my Netgear Router using WEP encryption which worked fine. I had to do some maintenance of my PC which to cut a long story lead me to step up the encryption of the router to WPA2. This wasn't a problem and my Laptop reconnected fine. However my iTouch didn't. I reset the network connection and it finds my network SSID however when I enter my password it tells me "Cannot join the network "

I get no IP address/subnet/dns entry in the DHCP section and all walkthroughs I have read simply state that you need to reset the network connection in the iPod Touch .... which doesn't work for me.

I am banging my head against brick wall and I even tried disabling the wireless encryption totally but without any joy??

Does anyone have any ideas?

share|improve this question
up vote 2 down vote accepted

This seems to be a common problem (or at least it was in 2008) - see this thread.

One solution mentioned here is:

under your router settings make sure the encryption algorithm is TKIP.

I've found the same problem on another forum. In this case the solution was:

I changed a setting on the Trendnet so that it is using AES and the Preshared Key and that is now working. I sent an audio clip of my conversation with Apple support to the buzz email.

share|improve this answer
    
Thanks for this. I will try tonight!! – Dean Nov 27 '09 at 12:44
1  
Getting WPA2 working on the router would be ideal as WEP is not secure and should not be used. Looks like ChrisF has the solution. – ridogi Nov 28 '09 at 1:38
    
Did either option work? If so which one? I'm experiencing similar issues with the device claiming a full strength encrypted connection but not pulling down any DHCP settings properly. – scunliffe Jan 11 '11 at 1:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .