Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 machine running VirtualBox with an Ubuntu guest. The guest has a Bitnami LAMP stack installed. I have the guest configured for Bridged networking, and I can access the guest web server just fine from other machines on my LAN using the guest's IP.

I'm trying to configure port forwarding so that I can access the web server from outside my LAN. (The router is a 2WIRE model as I'm on ATT's UVerse). I've set up port forwarding for ports 80 and 443 to the guest's IP in a similar manner to how I had them set up for my previous, physical web server, which worked just fine.

However, I cannot seem to access the new, virtual web server using my external IP on the forwarded port.

I suspected Windows Firewall issues on the host, but disabling it didn't solve the issue. Anyone have advice on what I should try next?

EDIT: I've now attempted disabling the firewall on the guest with sudo ufw disable -- that doesn't seem to help either. However, after checking the router's port forwarding in more detail I may see the problem. My VM is named "linux" and in the router's configuration pages it shows up inconsistently. Sometimes it reports with a valid LAN IP and other times it doesn't show up with any IP. Even when it shows the correct IP the router indicates that it is disconnected.

Could this be an indication that the 2WIRE router doesn't play well with VirtualBox's bridged networking mode?

share|improve this question
    
Are you testing from inside your network, or externally? Your router may not be able to port forward packets originating from your internal network. –  heavyd May 27 at 21:44
    
I've tested from both inside and outside the network; both fail. This same port forwarding configuration worked fine from both inside and outside my network with the original, physical web server. –  mwigdahl May 27 at 21:45
    
Just to check the obvious. Is apache turned on and have you used ifconfig in guest to ensure you have the right IP to forward onto. Windows Firewall won't affect this. No need to worry there. –  Matthew Williams May 27 at 21:59
    
Yep, Apache is on and I have confirmed the guest IP using ifconfig -- the guest and router both see the same IP. –  mwigdahl May 27 at 22:22

1 Answer 1

up vote 1 down vote accepted

Depending on the internet access plan you are paying for, some isps block specific ports such as port 80 to keep 'residential' customers from running web or email servers. To diagnose this, try running the httpd server on an alternate port such as 8888.

Also, make sure you assign a static private IP address to the virtual guest. Don't use dhcp. Then port-forward from your router to that IP address. Don't depend on network names when port-forwarding: I find them unreliable.

share|improve this answer
    
I will give those suggestions a try, thanks! –  mwigdahl May 28 at 2:22
    
Port 80 is not blocked, and I didn't need to assign a static IP, but the router's port forwarding did not register the proper LAN IP until I specifically selected that IP in the router's configuration. Working correctly now. Thanks! –  mwigdahl May 28 at 2:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.