Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I realize there is another question with the same title, but my situation is very different.

Any ideas?

share|improve this question
    
Using Firefox, I have just discovered that both problematic sites use certificates issued by Comodo – gdelfino Jan 25 '10 at 14:22
    

I had this problem as well. Adding new root authority certificates from Thawte fixed the problem. Apple has documentation on how to do this here http://docs.info.apple.com/article.h...en/mh2046.html

I added the root and server certificates that I downloaded from here http://www.thawte.com/roots

share|improve this answer
    
Thanks. Did you have to go through all the 8 directories and 14 subrectories double clicking on every .cer and .pem file? Did you add them to your login keychain or to the system keychain? – gdelfino Nov 27 '09 at 18:27
1  
There are dozens of certificates in that download. Which one do I need? – gdelfino Jan 25 '10 at 14:02
up vote 1 down vote accepted

I have just solved this problem by following this procedure published by phurd99 in the Apple Support Forums:

  1. Open applications
  2. Utiliities
  3. Open Keychain
  4. Click Keychain Access and select Preferences.
  5. Click the "Reset My Default Keychain"

(...)

http://discussions.apple.com/thread.jspa?threadID=2138178&start=15&tstart=0

This solves the problem but you are left without you precious keychain (a backup is saved).

Then, using the backup and trial and error I discovered that by deleting one specific certificate, the problem is solved:

UNT-USERFirst-Hardware
Intermediate certificate authority
Note: This certificate is signed by an untrusted issuer

share|improve this answer
1  
[+1] Searching for UNT-USERFirst-Hardware revealed 2 such certificates on my machine. One indeed was noted as signed by an untrusted issuer. So I just deleted this certificate and my HTTPS problems with Safari were gone! I couldn't use MobileMe on my MBA because of this. Thank you very much! – Marc Dec 12 '10 at 21:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .