Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently relocated and the network I have been provided blocks every outgoing TCP port except for

80          (http)
443         (https)
465         (smtps?)
587         (submission)
993         (imaps)
25565       (minecraft?)
27014-27050 (steam?)

I have been trying to use PIA's VPN client which I assume is trying to use PPTP (correct me if I'm wrong). How can I connect to it?

In a possibly misguided attempt, I have tried using sshuttle to redirect all of my traffic. It still wouldn't let me connect to the VPN.

share|improve this question
    
Have you checked UDP ports? OpenVPN uses UDP firstly (it can also use TCP, as a second best). –  MariusMatutiae May 29 at 15:03
    
@MariusMatutiae UDP ports appear to be open –  Jeffrey May 29 at 22:24

3 Answers 3

If outgoing VPN ports have been blocked and you need to connect to remote ports that can't be changed then you're pretty stuck. Our workplace does this and there's nothing I can do about it - they've given a valid security reason so I've got to lump it. Unless... Your VPN server is Microsoft and uses SSTP - this uses HTTPS to connect over the usually open port 443... Not many places have this due to the cost...

share|improve this answer

PPTP has a different transport layer protocol, which is neither UDP nor TCP and is thus likely to be blocked.

The simplest way to go around the limitations of your network would be to use a VPN service that uses one of the allowed ports. One such solution is OpenVPN, which uses an SSL based protocol and can be configured to use port 443, making it look more or less like a regular HTTPS connection.

share|improve this answer
    
How can I check to see if GRE is blocked on the network? –  Jeffrey May 29 at 11:45

I was wrong! The VPN client tries to use OpenVPN by default. I had it set to use a UDP port and I guess the UDP connections were taking too long to connect. I changed the settings to use TCP 443 and now it works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.