Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having a weird problem with F5 key.

the system continuously detect F5 key press. If I open web browser,tabs keeps refreshing.Detect keypress even while booting from external USB device(live linux)

This is what I've done,

  • Tried different os - win7 win8 ubuntu
  • tried removing keyboard
  • RAM test - all clear

Still problem not solved.

laptop details:hp g6-2015tx

share|improve this question
2  
Did you actually remove the keyboard from the laptop? – Art Gertner May 29 '14 at 14:00
    
Yes I removed keyboard from laptop physically. – Parth Parikh May 29 '14 at 14:07
1  
That sounds very weird. if the keyboard is removed, then there is no physical device from which the signal could possibly come. So we cannot assume stuck key or something. I don't want to disappoint you, but if all data you provided is correct, then it sounds like MB problem. Maybe something with keyboard controller or with keyboard connector. – Art Gertner May 29 '14 at 14:12
    
Everything I said is true I have made video of it I can upload it if you want evidence. – Parth Parikh May 29 '14 at 14:19
    
I did not mean to doubt it. I only meant that there is always room for human error. Double check if your keyboard connector is clean (I assume it is ZIF connector). Give it a gentle brush. That is all that comes to my mind. – Art Gertner May 29 '14 at 14:21

Have you tried using an external keyboard? As this may clear any cache the system has and also would confirm it's a mother board issue. The Keyboard may not work 1st time as the drivers will be installing so plug it in give it 5-10 mins then restart the machine (just to be safe) and try the external.

I had a similar issue with a cursor/touchpad on a laptop and this seemed to resolve the issue.

Sorry I can't comment on this as I don't have enough cred yet :(

Hope this helps :)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .