Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Often at work I have to RDP into one server in order to get to another. And no, there's no chance of the network getting sorted out such that I can connect to all machines directly :)

I'm wondering if anyone has any good tips/tricks for working in this scenario. I tend to open RDP sessions full screen, so the way to get back to my desktop is to click the minimize or restore buttons on the toolbar the drops down from the top of the screen when you are using a full-screen RDP session. The problem is that when you log into A and then from there log into B, A's toolbar covers B's, so there's no easy way to get back to the desktop of A without logging out of B. At least as far as I can see. Maybe there's a keyboard shortcut that can pop you out of the innermost session?

At the moment, I try to not use full screen mode on the nested session, but apart from having to remember to set that before I connect, it reduces the workspace and is something I'd like to avoid.

share|improve this question
    
I love/hate dealing with this. I always envision throwing a few virtual machines and some VNC into the mix too. RDP to a server, bring up a virtual machine console running on the server, VNC from the virtual machine over to the Linux desktop next door, and from there SSH ...etc. Totally impractical and unnecessary, but... fun to envision? heh –  JMD Nov 27 '09 at 17:27
    
As an aside, try your source machine not be a Windows machine. That means you can send Ctrl-Alt-Del to the first hop and Ctrl-Alt-End to the second hop. –  Broam Mar 2 '10 at 18:07

2 Answers 2

up vote 7 down vote accepted

Uncheck the pin on the "outer" RDP's toolbar to hide it. You can still get to it if necessary (hold the mouse against the edge of the screen), and any inner RDP connection toolbars will be visible.

Alternatively, other RDP clients such as Remote Desktop Manager might have a different toolbar when you run them full screen, so you'll know the custom toolbar is for the outer connection and the standard toolbars are inner connections.

Edit: Microsoft Remote Desktop Client 7.0 allows you to move the RDP toolbar from side to side by dragging it. You can move the outer toolbar to the side so you can tell it apart from the others.

share|improve this answer
    
Just like BeOS... –  Kev Nov 30 '09 at 13:48
    
If the inner session's toolbar isn't pinned then moving the mouse to the top of the screen causes both to appear simultaneously with the outer session's bar on top of course. Setting the checkbox to make it appear is another thing you have to do in advance of opening the connection. And then you need to remember not to unpin it or you're screwed. It really is a poorly designed UI. I'll see if I can get updated to version 7 anyway. Thanks –  U62 Nov 30 '09 at 17:12
    
There's good news and bad news as always with Microsoft updates - the version 7 client is available for XP and does indeed solve the problem via the inelegant means of moving the toolbar. The bad news is for no apparent reason the toolbar is massive (covers the whole of the maximised window's titlebar and half it's menu bar!) and rendered in ugly Vista/Win7 style. –  U62 Nov 30 '09 at 17:50
    
I've been doing a lot of RDP the last couple of days. Yesterday at some point I had a top toolbar that was nested inside of another toolbar. Yet today, I had to move the toolbars to the side because they weren't nested. Moving the toolbars worked well, but I have to wonder why the nesting went away... maybe I was on Win8 when I saw it. –  jcollum Dec 4 at 21:34

I generally try to set the "inner" session's resolution to something slightly less than the outer RDP's "fullscreen" size. That negates the overlapping RDP command tabs at the top, and the aggravation of competing task bars that may or may not be set to Autohide (or worse, both set to not Autohide, leaving one forver hidden.)

Once I have the settings the way I want for the inner one I just save a .RDP with the dimensions I want, ensuring I don't have to twiddle manually every time I connect.

share|improve this answer
    
That's what I do already - as I stated in my question, I'd like to avoid it. –  U62 Nov 27 '09 at 18:19
    
Maybe I misread your question, but "I tend to open RDP sessions full screen" doesn't sound at all like you do that. It sounds like you have a fullscreen session inside a fullscreen session which is the cause of your overlapping problem. –  JMD Nov 27 '09 at 18:48
    
read to the end –  U62 Nov 27 '09 at 22:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.