Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just got a das keyboard today, got it plugged in to my computer... and nothing.

Literally, nothing, nothing at all happened. No "Device Not Recognized;" no New Hardware Detected wizard, not even the usual "Da-dum!" sound I get when I plug in any hardware. I tried it with and without the cable that comes with it (it has a Y cable for USB, it says to try that if the keyboard doesn't work when you plug it in).

Strangely, both the keyboard and USB ports work just fine--but not in Windows. I can fool around in my BIOS just fine with it, and the same holds true for GRUB and Linux. I think this is something I might have inadvertently caused in the past, though. I have quite a few services that I'd never used disabled, but at the same time, I don't think that's the issue, any services that "make sense" to me to have running are running, those being HID Input Service, Plug and Play, and Shell Hardware Detection (although, I don't think this does much for keyboards).

It's worthy of note that when I plug the keyboard in and have Device Manager open, I can see it refresh, as if reacting to a change, but nothing on the list changes, not under Unknown Devices nor Keyboards, HID

In short: I'd like to know how to fix this issue: I plug in a keyboard, it is not recognized. The keyboard works, the USB port works, the OS works with different keyboards. No notification of failure of success is given when it's plugged in.

I'm plugging the keyboard directly into the USB ports on the motherboard, which is an ASUS P4P800-E Deluxe. I'm running Windows XP MCE SP3

share|improve this question
Bit of an update: I was able to make it work, albeit incredibly laggy, through my G15's USB ports. The G15 uses the power from one USB 2.0 port on my motherboard and has two USB 1.1 ports on its back. I've tried plugging the Das Keyboard into that exact port, no luck. Any help/suggestions would be greatly appreciated. – Zack Nov 28 '09 at 22:42
up vote 1 down vote accepted

It will show up under Usb devices as an Unknown Device.. sometimes.

I gave up after about a year of frustration.. (ice) cold booting worked.. completely power down, remove the plug from the wall, wait a few, don't plug in anything but the keyboard/monitor/power and try to login, if it fails, shutdown/restart again. Try all the USB ports, make sure its a full-power USB2 port if possible. If necessary, uninstall all USB ports/devices then shutdown.

It still works beautifully in BIOS/DOS/linux/my laptops/LiveCD's.. just not the work box's XP.. odd. Stupid dell.. so much easier to blame you than Das!

Some slight googling suggests replacing the mobo battery might help.. don't see how, but anything would be worth a shot, I know how great that kb is! Some more ideas here:,8.html Which is a phenomenally long thread, full of people suffering the same thing with a multitude of devices.. and all the varied ways they have attacked the problem.. its not just Das.. apparently it could be the chipset itself, which rebooting resets, and resistalling mobo drivers might be the ticket.. (haven't tested yet)

share|improve this answer
Well if you happen to have another USB keyboard with USB ports on it lying around, I'd try plugging it into that. It's... very strange, but it works for me. I plugged my G15 into the motherboard, then the Das into the G15 and, voilà, it works in XP! I have -no idea- why. Also, it works in 7 out of the box. – Zack Feb 21 '10 at 17:01

The Das Keyboard takes a lot of power from the USB hub. Try either unplugging everything else or plugging it into a powered hub. If that doesn't work, you may have a bad keyboard.

share|improve this answer
This makes me wonder, though, why would it work in the BIOS or Linux environments? Seems like it -should- work in XP, since none of the hardware changes. – Zack Nov 28 '09 at 0:14
I can't explain it, but I know the Das Keyboard is on the edge power-wise. I've seen other devices not enumerate when it is plugged in. A powered hub solved the issue. If you haven't tried yet, give it a shot. – Steve Rowe Nov 29 '09 at 0:54
Hmm, I tried something similar, but it makes very little sense as to -why- it actually worked. I plugged the Das Keyboard into my G15, and then plugged the G15 into the motherboard... and it worked. I'm... baffled, heh. – Zack Dec 4 '09 at 19:58
Steve, from the bottom of my heart I want to thank you. I've been having the weirdest USB issues on only ONE of my machines with a DAS Keyboard, and I'd never solve this without reading your post. – damageboy Mar 9 '11 at 21:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .