Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Through a local network, all computers except one ubuntu machine can access 1. Adobe.com 2. Icann.org 3. Apache.org 4. Example.com.

The ubuntu machine returns (in firefox): "Though the site seems valid, the browser was unable to establish a connection."

Furthermore, when I traceroute those websites using the ubuntu machine, they all return ubuntu.local, and it ends there:

(traceroute to icann.org (192.0.32.7), 30 hops max, 40 byte packets
1 ubuntu.local (192.168.1.105) 3000.791 ms !H 3000.808 ms !H 3000.814 ms !H

I've checked the hosts file, and there isn't anything in there, and I have an apache server there so if it was redirected to localhost, I'd probably see the localhost webroot page.

Thanks in advance!

user@ubuntu:~$ netstat -nr
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth1
192.0.0.0       0.0.0.0         255.0.0.0       U         0 0          0 eth1
0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 eth1

The Ubuntu Machine is one of six on the network.

I'm using opendns for dns, so I do think that should be a problem.

share|improve this question
2  
Do you have an inhouse DNS server? Do you hav any outdated manually entered DNS entries? Have you flushed the DNS cache on this machine? –  ridogi Nov 28 '09 at 4:08
    
is that the only Ubuntu machine on the network? –  quack quixote Nov 28 '09 at 18:35
    
The Ubuntu Machine is one of six on the network. I'm using opendns for dns, so I do think that should be a problem –  CodeJoust Nov 30 '09 at 23:08
    
i saw your note about the openID weirdness and merged your accounts together. you can accept an answer to this question now. –  quack quixote Apr 22 '10 at 6:41

2 Answers 2

I think that it's no coincidence that all of those hosts' IP address start with 192. I suspect you have an odd route in your routing tables. What does netstat -nr report?

Based on your netstat results, I believe that the netmask of eth1 is incorrect. It should be 255.255.255.0, but it is most likely 255.0.0.0. This will cause the ubuntu box to believe that everything starting with 192 is on the local LAN and won't attempt to send those packets to the router. ifconfig eth1 will tell you what your netmask is set to.

The solution depends on how you are configuring that interface. /etc/network/interfaces will tell you how it's configured. If it's configured via DHCP then you will need to fix your DHCP server. If it's configured static, then you can edit the file and change the netmask to the correct value, then do

ifdown eth1; ifup eth0
share|improve this answer
    
See edited question for netstat -r –  CodeJoust Nov 30 '09 at 23:12
    
This is me... something went wrong with openid... Anyways, thanks so much! It's all working perfectly. Typoes are tricky, and I had trouble with having the settings 'stay', (I didn't want to edit any configuration stuff because the gui works well, and when I did there were conflicts). –  CodeJoust Dec 1 '09 at 6:27

I had this same issue with Ubuntu 8, and it was the MTU setting on the router. My Belkin routher set it to 1432, so I -gedit-ed my "//etc/network/interfaces/" file by adding the line "pre-up /sbin/ifconfig $IFACE mtu 1432" after the "iface eth0 inet dhcp" line in the file.

See this thread for more hints if this doesn't fix your problem:

http://ubuntuforums.org/showthread.php?t=772234

Another suggestion is to check your "//etc/hosts/" to make sure it looks right. I had an error one time where it had an extra "hostname.home.net" added to my ip address/host name. I deleted that and my connections started working.

If these solutions don't work, it'd be helpful if you posted info about your version of ubuntu, your network setup (wireless/wan/?), and your DNS situation (see ridogi's comment).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.