Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use SharePoint 2010 via Internet Explorer 8 on Windows XP. I have a standard input mask for a task consisting of text fields, rich-text fields et al.

In text fields, I can use keyboard shortcuts (a.k.a. hotkeys) for editing (Ctrl-C/Ctrl-V) and formatting (Ctrl-B/Ctrl-I), but in the richtext field, none of them work. If I click on the appropriate button, however, the expected function is executed properly - but that is a tedious workaround.

What could be the cause? Could it be that the Ctrl key is not recognized at all?

(BTW: The problem is not reproducible in Firefox, because it doesn't show the rich-text controls at all. Why is another question.)

share|improve this question
    
did you find fix for this , I am facing exact same issue after upgrading SP2010 to SP2 and April 2014 CU , Which version of SP you are on ? –  user331831 Jun 9 at 19:32
    
I am only a mere user, so I don't know which SP we are on. Is there a way to look it up short of asking an admin? –  zoagli Jun 11 at 11:43

1 Answer 1

If you have upgraded your site from a previous version of SharePoint to SharePoint 2010, you have to enable the new user interface (with the Ribbon) on your site before keyboard shortcuts will work as expected in rich text fields.

As shown in this help document for SharePoint 2010, the standard keyboard shortcuts only make the button to make the change active, not actually make the change. For example, pressing CTRL+B would select the "bold" button on the interface, not actually make the text bold. You would then press the Enter key to activate the button. This is also the standard functionality for SharePoint 2007.

  • Activate or place focus on the Bold button. CTRL+B
  • Activate or place focus on the Copy button. CTRL+C
  • Activate or place focus on the Italics button. CTRL+I
  • Activate or place focus on the Underline button. CTRL+U
  • Activate or place focus on the Paste button. CTRL+V
  • Activate or place focus on the Cut button. CTRL+X

By upgrading your UI, you get the standard bold, underline, italics and alignment shortcuts that you get in Word. You also have to be cautious, as pasting text now also pastes the formatting from the source pretty poorly.

  • Apply or remove bold formatting from the selected text. CTRL+B
  • Apply or remove italic formatting from the selected text. CTRL+I
  • Apply or remove the underline from the selected text. CTRL+U
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.