Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

chrome

ie

My screen resolution is actually 3200x1800, but when I'm in a browser it acts like I have a smaller resolution. How do I get my browsers to use my full resolution?

On Chrome it's using 1280x720, and on IE it's using 1600x900. According to whatismyscreenresolution.com, which is showing different values for different browsers. I took a screenshot of them and verified that my resolution is 3200x1800 as that is the pixels in the bitmap.

I'm on a laptop with no monitor plugged in. My zoom in both browsers is at 100%. I've tried zooming out below 100% but then the text is unreadable and pixellated. I've tried restarting. Windows 8.1. I've tried the chrome extension OptiZoom and it does nothing. document.body.clientWidth gives 1247, and I want it to give 3200.

share|improve this question
    
Try whatis.myscreenresolution.com it can detect the correct resolution even if you're on a hidpi monitor –  Lưu Vĩnh Phúc Jun 3 at 10:37
    
@LưuVĩnhPhúc - It's actually whatismyscreenresolution.com. You have an extra . in there. –  Bobson Jun 3 at 18:32
    
@Bobson no it's actually a different website. whatismyscreenresolution.com cannot detect the real resolution while whatis.myscreenresolution.com can display the correct resolution when you're in hidpi mode like the OP –  Lưu Vĩnh Phúc Jun 4 at 0:55

2 Answers 2

up vote 11 down vote accepted

Possible Problem

This is most likely an issue caused by Window 8.1 "Display Scaling" feature. See a relevant post in the Google Chrome forum.

Possible Solution

Try disabling this feature for your browsers. For example, locate the Chrome executable which is commonly found in %ProgramFiles(x86)%/Google/Chrome/Application/. Right click the file, select "Properties" and then under the "Compatibility" tab tick the box saying "Disable display scaling on high DPI settings"

enter image description here

share|improve this answer

Well, it’s pretty obvious this is yet another example of DPI scaling gone horribly wrong.

Chrome is party to blame too. According to this article, there are (well, were) some possible workarounds.

  • Disable DPI scaling in Chrome’s compatibility settings (Properties on executable or shortcuts)—last resort “solution”
  • Go to chrome://flags and enable experimental Windows HiDPI support. (Gone now, apparently)
  • Load the following .reg file:

    Windows Registry Editor Version 5.00
    
    [HKEY_CURRENT_USER\Software\Google\Chrome\Profile]
    "high-dpi-support"=dword:00000001

A word of warning though: HiDPI is under development and has issues. If you cannot live with that, I suggest you try an alternate browser like Firefox. It’s supposed to have better DPI scaling support.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.