Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After using my external hard drive on another Windows 7 computer to tweak photos with Windows Live Photo Gallery then upload them to Facebook I found the modified images were now not visible on the original Windows 7 computer.

I'm not sure if the things I tried to get it working subsequently changed anything, but I do know this is the sequence of actions that makes the permissions of the modified files match those of the unmodified files:

  1. Right click on broken image file, select "Properties"
  2. On the "Security" tab press the "Advanced" button
  3. In the "Permissions" tab press the "Continue" button with the shield icon on it
  4. Tick the box marked "Include inheritable permissions from this object's parent
  5. Click the "Remove" button to remove the only current entry "Type: Allow, Name: Administrators (XYZ\Administrators), Permission: Full control, Inherited From:
  6. OK on the "Permissions" tab. OK on the "Security" tab.

Now this same procedure does not work at the folder level. It results in "access denied" dialogs.

I'm looking for some way to perform this exact modification on all the images I edited on the other computer.

I'm happy to use the Windows GUI in Explorer or any other included tools.
I'm happy to use the Windows command line.
I'd prefer not to use a third-party tool since I'd have to be satisfied it's not doing anything else.

I'm not looking for a different way to change permissions to other settings to make an external drive full of photos editable on multiple computers. At least not in this question.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.