Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am currently setting a Virtual Machine for development purposes. I did a big part of this configuration under Wheezy, but I need some debs that were available only on Jessie.

So, I've updated the sources.list and did a dist-upgrade.

Everything went well, but after the reboot, I noticed that I lost all the networking. Repositories are unreachable, as well as a simple ping google.fr returns nothing.

What can I do to quickly restore networking so that I can continue my working.

I have a poor connexion and can not afford to download the whole install DVDs.

root@vm~# ifconfig
lo    Link encap:Boucle locale
      inet adr:127.0.0.1 Masque:255.0.0.0
      adr inet6::1/128 Scope:Hôte
      UP LOOPBACK RUNNING MTU:65536 Metric 1
      RX packets:452 errors:0 dropped:0 overruns:0 frame:0
      TX packets:452 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 lg file transmission:0
      RX bytes:164238 (160.3 KiB) TX bytes:164238 (160.3 KiB)

root@vm~# 

I am running VMware 1.0.1 build 1379776 and the last update of Jessie (debian 3.14.4-1)

Solved !

I solved it by add the following in /etc/network/interfaces :

auto eth0
iface eth0 inet dhcp

Please help. Thanks.

share|improve this question
    
Try using a different network adaptor type in the VM config; it looks like it's not being recognised by the jessie kernel. –  Flup Jun 4 '14 at 8:52
    
I've tried all the adaptors. I also tryed /etc/init.d/networking restart No change :-/ –  Charaf Jun 4 '14 at 9:01
    
Try updating the vmware tools on that VM. –  Flup Jun 4 '14 at 9:02
    
I solved it by add the following in /etc/network/interfaces : auto eth0 iface eth0 inet dhcp –  Charaf Jun 4 '14 at 9:48
    
If you want to install a single package in Debian, you do not need to update the whole system. It can be done with three commands by inserting the repos for Testing and Unstable in /etc/apt/sources.list, fixing the distro you (mostly) wish by setting APT::Default-Release "stable" in /etc/apt/apt.conf.d/local, then doing aptitude install packagae_name/testing -t testing. –  MariusMatutiae Jun 4 '14 at 13:53

1 Answer 1

I met a similar problem and solved it by removing .dpkg-new suffixes from script names in /etc/wpa_supplicant. Maybe it would be useful for somebody.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.