Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Every file or link in my CentOS /usr/bin has an astericks at the end of it. None of them do on my local osX server. What does this mean? I have searched google and here specifically with no luck.

-rwxr-xr-x 1 root root 107104 Nov 11 2010 zipcloak* -rwxr-xr-x 1 root root 2953 Oct 10 2008 zipgrep* -rwxr-xr-x 1 root root 159928 Nov 11 2010 zipinfo* -rwxr-xr-x 1 root root 98584 Nov 11 2010 zipnote* -rwxr-xr-x 1 root root 102680 Nov 11 2010 zipsplit* -rwxr-xr-x 1 root root 1731 May 27 2013 zless* -rwxr-xr-x 1 root root 2605 May 27 2013 zmore* -rwxr-xr-x 1 root root 5246 May 27 2013 znew*

share|improve this question
    
Related: What are = and | in the output of “ls -F”? from Ask Ubuntu. – Cristian Ciupitu Jun 4 '14 at 19:44
up vote 2 down vote accepted

That's an indicator showing that the files are executable. From the documentation for ls, section "General output formatting" (info coreutils 'general output formatting'):

‘-F’
‘--classify’
‘--indicator-style=classify’
    Append a character to each file name indicating the file type.
    Also, for regular files that are executable, append ‘*’.

Your system probably has an alias for ls which is expanded to ls -F.

The ls from Mac OS X has this option too, but you'll have you use it explicitly i.e. run ls -F.

-F  Display a slash (`/') immediately after each pathname that is a
    directory, an asterisk (`*') after each that is executable, an
    at sign (`@') after each symbolic link, an equals sign (`=') after
    each socket, a percent sign (`%') after each whiteout, and a
    vertical bar (`|') after each that is a FIFO.
share|improve this answer
    
yup. there are the astericks when I run ls -F on the mac. thank you! – MikeiLL Jun 4 '14 at 21:46

GNU ls offers the option -F which causes file names to be suffixed with certain characters indicating the type of file:

   -F, --classify
          append indicator (one of */=>@|) to entries

where * signifies an executable file, / signifies a directory, = signifies a socket, etc. It's likely that the listing command you're using on your CentOS box is aliased to something like /bin/ls -lF. If you type /bin/ls -l /usr/bin on your CentOS box, then the * will disappear.

Try typing ls -lF on your OSX server and see if that works. Note that the ls that comes with OSX is not GNU ls; it is OpenBSD ls, which might not support -F (I'm not sure). Type man ls on OSX to see what options it supports. (You can also install GNU fileutils on OSX using macports.)

share|improve this answer
1  
If I'm not mistaking Mac OS X got its a lot of its programs including ls from FreeBSD, not OpenBSD. Also Fileutils, Shellutils, and Textutils have been combined into the GNU Coreutils package. – Cristian Ciupitu Jun 4 '14 at 18:18
    
Good points. It has been 3 years since I had to think about this on my current Mac. You may be entirely correct. – dg99 Jun 4 '14 at 18:23
    
It looks like the macport is named coreutils too, not just the upstream project. – Cristian Ciupitu Jun 4 '14 at 18:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .