Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm not sure this is the appropriate stack exchange site to post this question on. If not, please flag this for migration.

I am trying to use PuTTy ssh into my ubuntu machine which is wirelessly connected to the same network. I originally ran ifconfig to get my ubuntu machines private network IP address. I then verified that ssh was running, I even ssh'd into my school network and then into the ubuntu machine itself. No problems yet.

On my windows 8 machine I ran ipconfig to get my private network IPv4 address. I then pinged my ubunty machines IP and 100% of packets were received. I figured, "OK we are ready to use PuTTy to connect to my Ubuntu Machine". Keep in mind this was my first time using PuTTy. I tried entering the IP of my ubuntu machine in the PuTTy Config GUI but I got a connection timeout. At this moment I don't really know what's going on, SSH is running on port 22 of my Ubuntu machine and I can ping the machine why is it not connecting? (I tried [username]@ip too).

So I went on my Ubuntu machine and ran nmap -sP 192.168.0.1/24 and found that my windows machines IP did not show up, the host is down. I'm at a lost in something I am not very familiar with. Would anyone be able to help me or direct me to some resources that would trouble shoot my problem?

Thank you

EDIT (ADDITION): tyler@tyler-Aspire-5250:~$ nmap -v 192.168.0.123

Starting Nmap 6.40 ( http://nmap.org ) at 2014-06-06 01:56 MDT Initiating Ping Scan at 01:56 Scanning 192.168.0.123 [2 ports] Completed Ping Scan at 01:56, 3.00s elapsed (1 total hosts) Nmap scan report for 192.168.0.123 [host down] Read data files from: /usr/bin/../share/nmap Note: Host seems down. If it is really up, but blocking our ping probes, try -Pn Nmap done: 1 IP address (0 hosts up) scanned in 3.14 seconds tyler@tyler-Aspire-5250:~$ nmap -Pn 192.168.0.123

Starting Nmap 6.40 ( http://nmap.org ) at 2014-06-06 01:56 MDT Nmap scan report for 192.168.0.123 Host is up (0.022s latency). Not shown: 998 filtered ports PORT STATE SERVICE 2869/tcp open icslap 5357/tcp open wsdapi

Nmap done: 1 IP address (1 host up) scanned in 72.51 seconds

share|improve this question
1  
Please try connecting with the -v option: it increases the verbosity. Then post the results here. –  MariusMatutiae Jun 6 at 6:59
    
@MariusMatutiae I've added the the output above –  user1787262 Jun 6 at 8:05

1 Answer 1

The output of nmap you posted does not help me much, the post I asked for would be more conclusive. Yet the presence of 998 filtered ports suggests, without truly establishing, the presence of a firewall. So what I can suggest is that you check your own Windows firewall, trying to establish whether outgoing connections on port 22 are allowed.

If they are blocked, then this is surely the root cause of your problems: you should allow ssh connections, i.e. those occurring on port TCP-22.

share|improve this answer
    
My apologies Marius, I thought that was what you were asking for. I believe it might have to do with my windows firewall. When I get back home from work I will set new rules to allow outgoing connections on port 22 and report back –  user1787262 Jun 6 at 8:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.