Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Emacs 24, and due to a separate issue, my input method (uim-el) displays input candidates in the minibuffer regardless of how I set its options. That would not be such a problem if the minibuffer did not resize from height 2 (when displaying candidates) to height 1 (when not), repeatedly, as I scroll through candidates--it's really jarring.

I looked through the documentation online and searched the configuration pages, but I couldn't find a setting for this. Is it possible?

share|improve this question
up vote 1 down vote accepted

Try setting input-method-use-echo-area to nil and echo-keystrokes to 0.

If that doesn't help, try setting resize-mini-windows to nil.

(You can also try setting max-mini-window-height to 1, but that will likely truncate your echoed input-method candidates.)

share|improve this answer
I don't seem to have any of the first three variables available to modify. – Trevor Alexander Jun 10 '14 at 2:39
You must have at least the first two, unless your Emacs version is older than Emacs 20 (and even then I'm pretty sure you have at least the second one). If you have Emacs 22 or later then you must have all of them. Try C-h v for each. Some are not use options -- you can set them using setq. – Drew Jun 10 '14 at 2:47
Whoops. I found the first two, but not resize-mini-windows. Neither one seems to help. – Trevor Alexander Jun 10 '14 at 2:59
Wrt resize-mini-windows: Is your M-x emacs-version less than Emacs 22? If not then that variable should exist (it is in Emacs 22.1, the first 22 release). And it is the variable most likely to solve your problem, I believe. Sorry that the others don't help. – Drew Jun 10 '14 at 13:32
Strange, reinstalling emacs24 on a fresh system, even with a restored home directory fixed the problem, and made that variable available. – Trevor Alexander Jun 16 '14 at 0:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .