Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have problems putting Windows to sleep and starting the screen saver on my new Windows 8.1 machine.

Sleep mode and screen savers work only when the computer is first powered up (or restarted). But once it goes to sleep (manually or automatically) and I wake it up later, it wont go back to sleep again and I can't use screen savers either.

I updated the chipset and graphics card drivers. My computer isn't part of a homegroup either. Does anyone else have similar issues?

Thanks for your advice, per

share|improve this question

1 Answer 1

Start the command prompt (WIN+R → "cmd" → OK) and use this command to check what sleep states are available for your computer:

powercfg -a

If it doesn't say Hybrid Sleep in the list of available sleep states, you might need to update your graphics card drivers.

If that doesn't help, try running the troubleshooter and troubleshoot for power related problems

As for the screensaver issues, you might want to look into this. Some users seem to be facing these problems after installing Windows Update 2756872. If you have that update installed, try uninstalling it to see if that fixes the issues.


This solution will enable Windows machines (Vista or later) to start a batch file after resuming from sleep (possibly hibernation as well). The script will use PsShutdown to put the computer back to sleep after waiting for 15 minutes.

  1. Download and install Hibernate Trigger and PsShutdown. Run PsShutdown at least once and agree to the license agreement.

  2. Move psshutdown.exe to the folder where Hibernate Trigger is installed

  3. Edit the suspend.ini file present in the folder (open it using Notepad) and make sure it contains the following lines:

  1. Create a batch file in the folder called GoToSleepAgain.bat and add the following lines in the script:
REM increase the timeout value if you need the computer to wait for more than 15 minutes
timeout /T 900
psshutdown -d -t 0
  1. Start HibernateTrigger.exe. Make sure that it is running in the system tray. You might want to test it out by putting the computer to sleep manually and then waking it up again.
share|improve this answer
Thanks for reply, but it did not helped. I have Hybrid Sleep in powercfg -a list. I don't have Update 2756872 installed and troubleshooter did not helped. – per Jun 8 '14 at 18:12
Do you see a "Sleep" option under power options when your computer wakes up from sleep mode? – Vinayak Jun 8 '14 at 19:32
Yes and I can put computer to sleep manually. – per Jun 8 '14 at 20:36
Let me rephrase that: Do you see a "Sleep" option after your computer has woken up from sleep mode which was triggered manually or automatically? – Vinayak Jun 9 '14 at 18:30
Yes, and I can manually trigger it. Problem is, that "sleep" will not trigger automatically after first wake up from sleep. – per Jun 10 '14 at 6:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.