Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would like to log into my Ubuntu machine from my Mac. I tried running a VNC server on the Ubuntu machine with

 sudo x11vnc -shared -forever -nopw -display :0 -auth /var/lib/gdm/:0.Xauth

and then connecting in the finder to "Go to server->vnc://" but I get the "Contacting" dialog, but it never connects. On the Ubuntu side, I see this:

29/11/2009 03:42:03 Got connection from client
29/11/2009 03:42:03   other clients:
29/11/2009 03:42:03 Disabled X server key autorepeat.
29/11/2009 03:42:03   to force back on run: 'xset r on' (3 times)
29/11/2009 03:42:03 created xdamage object: 0x800036
29/11/2009 03:42:03 Client Protocol Version 3.889
29/11/2009 03:42:03 Protocol version sent 3.889, using 3.889
29/11/2009 03:42:03 rfbProcessClientSecurityType: executing handler for type 1
29/11/2009 03:42:03 rfbProcessClientSecurityType: returning securityResult for client rfb version >= 3.8
29/11/2009 03:42:18 XDAMAGE is not working well... misses: 77/225
29/11/2009 03:42:18 Maybe a OpenGL app like Beryl is the problem? Use -noxdamage
29/11/2009 03:42:18 To disable this check and warning specify -xdamage twice.
29/11/2009 03:42:19 cutbuffer_send: no send: uninitialized clients

I tried adding "-noxdamage" in the x11vnc command line, and it didn't help. I'm running Ubuntu 8.04.3 (x86_64) on the Linux side and Snow Leopard on the Mac side.

share|improve this question
up vote 3 down vote accepted

I would like to log into my Ubuntu machine from my Mac. I tried running a VNC server on the Ubuntu...

I am not the world most knowledgeable person on this topic, but - AFAIK - VNC is not a remote log-on utility but a program to share the desktop of an open session over the network (in other words: you must be already logged into the machine you want to see the desktop of).

If you want to be able to graphically log-in into a remote machine you will need some other tool instead. I have successfully managed that on xubuntu with freenx. I wrote a small how-to on serverfault. I believe you will only have to use GDM instead of the startxfce4 command and it should work.

Bear in mind that if this is the kind of functionality you are after, there are various other alternatives you can try, especially if you are using gnome. The "classic one" - if you trust the connection between the two computer (user and password are sent unencrypted) is XDMCP.

share|improve this answer
I ended up giving up on VNC and using xdmcp instead. – Paul Tomblin Nov 29 '09 at 16:39
actually with x11vnc you can connect to an existing X11 connection, that is, providing you also login... you have to configure your login screen to provide it, but it works – Juan Sebastian Totero Feb 27 '13 at 14:46

Instead of using VNC, what I did was the following:

  • enable xdmcp on the Linux box by editing /etc/gdm/gdm.conf-custom and setting "Enable=true" in the "[xdmcp]" section.
  • restart gdm
  • start X on the Mac using "sudo X -indirect"

And now I have a GDM window where I can log onto my Linux box. Unfortunately it's SLLOOOOOOW.

share|improve this answer

Perhaps too obvious, but did you try this? To disable this check and warning specify -xdamage twice. (you said you tried -noxdamage but that's not what the message said to do)

EDIT: Also, are you running Beryl or Compiz? You can stop Compiz by running metacity --replace in the run dialog (if you do this in a terminal, it will close when you close the window, even if you run it with an &).

share|improve this answer
All that does is suppress the warning, it doesn't make it work. – Paul Tomblin Nov 29 '09 at 13:34
Based on the other comments, I was assuming you knew how VNC works. I think your problem is just that you're trying to log into VNC when you're not logged in. – Brendan Long Nov 30 '09 at 0:45

I was able to connect to my Ubuntu machine from my Mac just as you tried to do using Chicken of the VNC instead of the built-in desktop sharing client.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .