Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an ASUS P7P55D LE motherboard with onboard sound and I am running Windows 7 64-bit, and I am using the SPDIF output from my motherboard to my receiver. On my receiver I can see which audio channels are in use (i.e. stereo or 5.1)

In the audio interface properties I can test DTS Audio and Dolby Digital outputs and both work fine, but when I try to play a game with 5.1 sound (I've tried Left 4 Dead and Dragon Age Origins) it reverts to stereo. I was getting this behaviour with the default Microsoft drivers so I installed the latest from the ASUS website but there is no difference.

I notice that in the Advanced tab of the playback device Properties dialog (accessed by selecting the device in the Playback Devices window in Windows 7 and clicking Properties) the Default Format only allows me to choose from various 2 channel formats so maybe that is something to do with it?

I also notice that in the Playback Devices dialog I can press the "Configure" button when I select the "Speakers" device (which is the analog output) and in the "Speaker Setup" dialog that then opens I can choose from Stereo/Quadraphonic/5.1 Surround (which I have selected) and 7.1 Surround. However, the "Speaker Setup" dialog only contains the Stereo option for the HDMI output, and for the SPDIF output (which is the one I want to use) the Configure button is disabled altogether!

When I look at the audio settings in a game the Speaker Configuration is shown as "Desktop stereo speakers" which reminds me of the audio settings in previous versions of Windows.

How can I get 5.1 output all of the time?

share|improve this question
3  
this sounds suspiciously more like a problem with the games than with your sound drivers. you're sure you've enabled 5.1 sound in the games' configuration? –  quack quixote Mar 14 '10 at 17:23
3  
You mention the Advanced tab, where is this tab? In the game? In Windows? Are you sure your game is outputting 5.1? –  heavyd Mar 16 '10 at 6:13
    
I'm sure it's not the games - I've never had this problem on other computers running Windows 7 (although 32-bit and with different audio devices). I've obviously checked them all for options to force stereo and found nothing. –  GraemeF Mar 19 '10 at 9:14
    
I've amended the question to clarify which Advanced tab I mean. –  GraemeF Mar 19 '10 at 9:15
    
Added information about the speaker configuration options, and the fact that they are disabled for the digital outputs. –  GraemeF Mar 21 '10 at 14:38

2 Answers 2

There are many reports of such problems, with so many possible solutions that it's impossible to cover them all.

In this thread, the solution was to uninstall the Windows 7 drivers and install the Vista ones.

In this thread, the problem was the audio cable.

In this thread, the solution was to turn off speaker fill and set the game's executable compatibility privilege level to "Run this program as an administrator".

And this is by no means the entire list. It might help to narrow down the problem, to know which version of Win7 you're using (32 or 64-bits) and whether your audio driver is the latest version (and which one).

share|improve this answer
    
I've ruled out the audio cable because I get Dolby Digital and DTS when I play a DVD, and as I said I'm using Windows 7 64-bit. I went to try the Vista drivers as you suggested and noticed that there is an updated version of the Windows 7 drivers, so I'll try that and then the Vista drivers if it still doesn't work. Thanks :) –  GraemeF Mar 21 '10 at 12:23
    
The drivers come as a single package for all versions of Windows since XP, so that doesn't seem like the right option (unless I'm supposed to extract the Vista ones from the installer but there was no mention of that on the thread you referenced). –  GraemeF Mar 21 '10 at 14:40
    
@GraemeF: In case you need it, a very good extractor is Universal Extractor found at legroom.net/software/uniextract –  harrymc Mar 21 '10 at 15:05

The issue is that you need a Dolby Digital or DTS encoder software to get 5.1 audio from games. You get 5.1 from movies because the audio is already encoded – it however is not free.

See also: Dolby Digital Live and DTS Connect Pack.

share|improve this answer
1  
That doesn't make sense – why would you need an encoder just to hear Dolby Digital or DTS output? –  slhck Jul 20 '12 at 1:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.