Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Why does clicking on tabs in Firefox sometimes fail until I hit cmd-Q, and then why does that not quit but instead make clicking on the tabs work, and how do I stop that behavior?

I'm running Firefox 3.5.5 on Mac OS X 10.5 and this has been happening for a while (with previous versions of FF as well). I can't forcibly reproduce the behavior, but every now and then (few days?) I just can't click on tabs or on the x's to close the tabs. I can still ctrl-tab between tabs, though. But if I press cmd-Q, instead of quitting, Firefox seems to seize for a second and then I can click on tabs and click to close them just fine. No clue why this is happening or how to stop it. And I do have tons of extensions installed, so it's plausible one of them is the problem..... Thanks.

share|improve this question
2  
what extensions? –  warren Nov 29 '09 at 16:17
    
Literally 30. New information though: this happens sometimes when a web page asks for access to my computer when it presents me with a form, and then I can also solve the problem by minimizing the window and then re-maximizing it (without the cmd-q business), which makes it a little less of a headache but still a curiosity. –  Philip Dec 31 '09 at 16:48

2 Answers 2

up vote 1 down vote accepted

Something to try is to start Firefox in Safe mode (no extensions), and see if the problem goes away.

If it is an extension problem, you can deactivate them in a binary search, to find the guilty extension.

share|improve this answer
    
It's a good idea in theory but the problem is that the behavior doesn't necessarily manifest even during an entire browsing session. So the absence of the behavior doesn't necessarily indicate that a turned-off extension is the culprit; it's possible that the behavior just isn't popping up for whatever reason it sometimes just doesn't pop up and not because I eliminated the responsible extension. –  Philip May 22 '10 at 14:18
    
@Philip: Might be a good idea to turn off as many extensions as won't cripple you too much for a few days. –  harrymc May 22 '10 at 17:54
    
Or to use Google Chrome :) –  Philip Jun 14 '10 at 13:27

Having the same issue with no resolve. OS X, firefox 3.6.3, with tab mix plus, firebug, and a slew of other extensions. Not sure what the issue is, but its quite annoying.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.