Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use a server a home to host a bunch of concurrently running Hyper-V VM's with different OS's and software for testing.

I have Vista on the laptop, all latest SP's and patches. The server is Server 2008 R2, fully patched. The guests are a mix of XP, Vista, Server 2008 and Windows 7.

If I connect to the Win XP or Server 2008 guest using RDP, it is always good. Very quick, no speed issues.

If I connect to the Vista or Win 7 guests, the response time is so slow it is unusable. Usually 6 or 8 seconds, and at times it is to long to measure! This happens from both the laptop running Vista, and the server running Server 2008 R2.

Does anyone know what the issue is with RDP on Vista and Windows 7 destinations?

I did read this: "http://blog.tmcnet.com/blog/tom-keating/microsoft/remote-desktop-slow-problem-solved.asp" and that is not the problem I have applied that change to all PC's.

share|improve this question

migrated from stackoverflow.com Nov 29 '09 at 16:02

This question came from our site for professional and enthusiast programmers.

1  
How is the speed if you RDP from one of the XP or Server 2008 guests to the Vista or Win 7 guests? –  Joseph Nov 29 '09 at 16:25
    
I have RDP'd from my Vista laptop into the Server 2008 R2 host, then connected to the Win7 guest using the Hyper-V manager, and in that session, RDP'd into the Windows Vista guest, and that worked great. No discernible lag. Yet when RDPing from my Vista lapto direct to the Vista guest, more than 7 seconds lag... –  MadBison Dec 3 '09 at 3:58

1 Answer 1

Disable TCP/IP auto tuning. Open an elevated command prompt and:

netsh interface tcp set global autotuninglevel=disabled
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.